]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/mm/Makefile.am
66AK2G: Linux: Add support for K2G
[ipc/ipcdev.git] / linux / src / mm / Makefile.am
index 5ba2e00463d2bcc7103f8af57974f06bb1e53617..59aa3128b054cf78c423339384957113c42b3202 100644 (file)
@@ -1,5 +1,5 @@
 ##
-##  Copyright (c) 2013, Texas Instruments Incorporated
+##  Copyright (c) 2013-2014, Texas Instruments Incorporated
 ##
 ##  Redistribution and use in source and binary forms, with or without
 ##  modification, are permitted provided that the following conditions
@@ -41,15 +41,29 @@ AM_CFLAGS = -Wall @AM_CFLAGS@ -DKERNEL_INSTALL_DIR="$(KERNEL_INSTALL_DIR)"
 # the library names to build (note we are building shared libs)
 lib_LTLIBRARIES =
 
+if OMAP54XX_SMP
 if KDIR
 lib_LTLIBRARIES += libmmrpc.la
+
+# where to install the headers on the system
+libmmrpc_ladir = $(includedir)/ti/ipc/mm
+
+# the list of header files that belong to the library (to be installed later)
+libmmrpc_la_HEADERS = $(top_srcdir)/packages/ti/ipc/mm/MmRpc.h
+endif
 endif
 
+if DRA7XX
+if KDIR
+lib_LTLIBRARIES += libmmrpc.la
+
 # where to install the headers on the system
-libmmrpc_ladir = $(includedir)
+libmmrpc_ladir = $(includedir)/ti/ipc/mm
 
 # the list of header files that belong to the library (to be installed later)
 libmmrpc_la_HEADERS = $(top_srcdir)/packages/ti/ipc/mm/MmRpc.h
+endif
+endif
 
 # the sources to add to the library and to add to the source distribution
 libmmrpc_la_SOURCES = \
@@ -59,4 +73,8 @@ libmmrpc_la_SOURCES = \
 # Add version info to the shared library
 libmmrpc_la_LDFLAGS = -version-info 1:0:0
 
+pkgconfig_DATA         = libmmrpc.pc
+pkgconfigdir           = $(libdir)/pkgconfig
+
+
 ###############################################################################