]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/mm/Makefile.am
Linux: Remove KERNEL and DRM requirement
[ipc/ipcdev.git] / linux / src / mm / Makefile.am
index 52c44b75cc817e084df5220df3f324f30a84cd9b..96dfa17e072dd1009ddfce7ee1672a7479011fb9 100644 (file)
@@ -41,6 +41,7 @@ AM_CFLAGS = -Wall @AM_CFLAGS@ -DKERNEL_INSTALL_DIR="$(KERNEL_INSTALL_DIR)"
 # the library names to build (note we are building shared libs)
 lib_LTLIBRARIES =
 
+if OMAP54XX_SMP
 if KDIR
 lib_LTLIBRARIES += libmmrpc.la
 
@@ -50,6 +51,19 @@ libmmrpc_ladir = $(includedir)/ti/ipc/mm
 # the list of header files that belong to the library (to be installed later)
 libmmrpc_la_HEADERS = $(top_srcdir)/packages/ti/ipc/mm/MmRpc.h
 endif
+endif
+
+if DRA7XX
+if KDIR
+lib_LTLIBRARIES += libmmrpc.la
+
+# where to install the headers on the system
+libmmrpc_ladir = $(includedir)/ti/ipc/mm
+
+# the list of header files that belong to the library (to be installed later)
+libmmrpc_la_HEADERS = $(top_srcdir)/packages/ti/ipc/mm/MmRpc.h
+endif
+endif
 
 # the sources to add to the library and to add to the source distribution
 libmmrpc_la_SOURCES = \