]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/tests/Makefile.am
Merge remote-tracking branch 'gil/3.00.00.10_eng' into 3.00.00.11_eng
[ipc/ipcdev.git] / linux / src / tests / Makefile.am
index a7606171db6b96ed385fa7fc66d8b23f32d26ae4..b4ddc709327be5ce5bd5ca3c00d15b37b052f5ed 100644 (file)
@@ -40,7 +40,7 @@ AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/packages  \
 ###############################################################################
 
 # the program to build (the names of the final binaries)
-bin_PROGRAMS =
+bin_PROGRAMS = ping_rpmsg
 
 if OMAP4430
   bin_PROGRAMS += MessageQApp_omap4430 MessageQBench_omap4430 \
@@ -89,6 +89,9 @@ nameServer_common_sources = \
                 $(top_srcdir)/packages/ti/ipc/NameServer.h \
                 NameServerApp.c
 
+# list of sources for the 'ping_rpmsg' binary
+ping_rpmsg_SOURCES = ping_rpmsg.c
+
 # list of sources for the 'MessageQApp' binary
 MessageQApp_omap4430_SOURCES = $(common_sources) MessageQApp.c
 MessageQApp_omapl138_SOURCES = $(common_sources) MessageQApp.c
@@ -119,6 +122,9 @@ nano_test_omapl138_SOURCES = $(common_sources) nano_test.c
 common_libraries = -lpthread $(top_builddir)/linux/src/api/libtiipc.la \
                 $(top_builddir)/linux/src/utils/libtiipcutils.la
 
+# the additional libraries to link ping_rpmsg
+ping_rpmsg_LDADD = -lrt
+
 # the additional libraries needed to link MessageQApp
 MessageQApp_omap4430_LDADD = $(common_libraries) \
                 $(top_builddir)/linux/src/family/libtiipccfg_omap4430.la \