]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/tests/Makefile.am
C66AK2E: Linux: Introduce support for C66AK2E
[ipc/ipcdev.git] / linux / src / tests / Makefile.am
index 6238155b0a9a03b313ecd491dd55588ff2c634ac..471ccd3b9c3aa7dcea54acd4f8d915a32fd92d34 100644 (file)
@@ -1,5 +1,5 @@
 ##
-##  Copyright (c) 2013, Texas Instruments Incorporated
+##  Copyright (c) 2013-2014, Texas Instruments Incorporated
 ##
 ##  Redistribution and use in source and binary forms, with or without
 ##  modification, are permitted provided that the following conditions
 ##
 
 # additional include paths necessary to compile the program
-AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/hlos_common/include \
-        -I$(top_srcdir)/packages -I$(CMEM_INSTALL_DIR)/packages \
+AM_CFLAGS = -I$(top_srcdir)/linux/include \
+        -I$(top_srcdir)/hlos_common/include \
+        -I$(top_srcdir)/packages \
+        -I$(KERNEL_INSTALL_DIR)/include/generated/uapi \
         -D_GNU_SOURCE -Wall @AM_CFLAGS@
+
+if DRM
+AM_CFLAGS += \
+        -I$(DRM_PREFIX)/usr/include \
+        -I$(DRM_PREFIX)/usr/include/libdrm \
+        -I$(DRM_PREFIX)/usr/include/omap
+endif
+
+if CMEM
+AM_CFLAGS += \
+        -I$(CMEM_INSTALL_DIR)/include
+endif
+
 VPATH = ../../../packages/ti/ipc/tests
 
 ###############################################################################
@@ -43,15 +58,26 @@ VPATH = ../../../packages/ti/ipc/tests
 
 # the program to build (the names of the final binaries)
 bin_PROGRAMS = ping_rpmsg MessageQApp  MessageQBench MessageQMulti \
-                NameServerApp
-               
+                NameServerApp Msgq100
+
 
 if OMAP54XX_SMP
 # Add platform specific bin application's here
   bin_PROGRAMS +=
 if KDIR
+if DRM
+  bin_PROGRAMS += mmrpc_test
+endif
+endif
+else
+if DRA7XX
+# Add platform specific bin application's here
+  bin_PROGRAMS +=
+if KDIR
+if DRM
   bin_PROGRAMS += mmrpc_test
 endif
+endif
 else
 if OMAPL138
 # Add platform specific bin application's here
@@ -60,25 +86,43 @@ if CMEM
   bin_PROGRAMS += nano_test
 endif
 else
+if C66AK2E
+# Add platform specific bin application's here
+  bin_PROGRAMS +=
+else
 if TCI6614
 # Add platform specific bin application's here
   bin_PROGRAMS +=
 else
+if TCI6630
+# Add platform specific bin applications here
+  bin_PROGRAMS +=
+else
+if TCI6636
+# Add platform specific bin application's here
+  bin_PROGRAMS +=
+else
 if TCI6638
 # Add platform specific bin application's here
   bin_PROGRAMS +=
 else
-# Add platform independent apps here or above in bin_PROGRMAS
+# Add platform independent apps here or above in bin_PROGRAMS
 if CMEM
   bin_PROGRAMS += nano_test
 endif
 if KDIR
+if DRM
   bin_PROGRAMS += mmrpc_test
 endif
 endif
 endif
 endif
 endif
+endif
+endif
+endif
+endif
+endif
 
 common_sources = \
                 $(top_srcdir)/linux/include/ti/ipc/Std.h \
@@ -88,7 +132,7 @@ common_sources = \
 nameServer_common_sources = \
                 $(top_srcdir)/linux/include/ti/ipc/Std.h \
                 $(top_srcdir)/linux/include/ladclient.h \
-                $(top_srcdir)/linux/include/_NameServer.h \
+                $(top_srcdir)/hlos_common/include/_NameServer.h \
                 $(top_srcdir)/packages/ti/ipc/NameServer.h \
                 NameServerApp.c
 
@@ -115,6 +159,9 @@ NameServerApp_SOURCES = $(nameServer_common_sources)
 # list of sources for the 'nano_test' binary
 nano_test_SOURCES = $(common_sources) nano_test.c
 
+# list of sources for the 'Msgq100' binary
+Msgq100_SOURCES = $(common_sources) Msgq100.c
+
 common_libraries = -lpthread $(top_builddir)/linux/src/api/libtiipc.la \
                 $(top_builddir)/linux/src/utils/libtiipcutils.la
 
@@ -122,7 +169,10 @@ common_libraries = -lpthread $(top_builddir)/linux/src/api/libtiipc.la \
 ping_rpmsg_LDADD = -lrt
 
 # the additional libraries to link mmrpc_test
-mmrpc_test_LDADD = $(top_builddir)/linux/src/mm/libmmrpc.la
+mmrpc_test_LDADD = $(common_libraries) \
+                $(top_builddir)/linux/src/mm/libmmrpc.la \
+                $(DRM_PREFIX)/usr/lib/libdrm.la \
+                $(DRM_PREFIX)/usr/lib/libdrm_omap.la
 
 # the additional libraries needed to link MessageQApp
 MessageQApp_LDADD = $(common_libraries) \
@@ -142,7 +192,11 @@ NameServerApp_LDADD = $(common_libraries) \
 
 # the additional libraries needed to link nano_test
 nano_test_LDADD = $(common_libraries) \
-                $(CMEM_INSTALL_DIR)/packages/ti/sdo/linuxutils/cmem/lib/cmem.a470MV \
+                $(CMEM_INSTALL_DIR)/src/cmem/api/.libs/libticmem.a \
+                $(AM_LDFLAGS)
+
+# the additional libraries needed to link Msgq100
+Msgq100_LDADD = $(common_libraries) \
                 $(AM_LDFLAGS)
 
 ###############################################################################