]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/tests/Makefile.am
tests: mmrpc_test: Add DRM library to Linux side makefiles.
[ipc/ipcdev.git] / linux / src / tests / Makefile.am
index 6238155b0a9a03b313ecd491dd55588ff2c634ac..7c9004a5133e52d05d86b4113ba379bfaf09cf29 100644 (file)
 
 # additional include paths necessary to compile the program
 AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/hlos_common/include \
+        -I$(top_srcdir)/packages -I$(CMEM_INSTALL_DIR)/include \
         -I$(top_srcdir)/packages -I$(CMEM_INSTALL_DIR)/packages \
+        -I$(DRM_PREFIX)/usr/include \
+        -I$(DRM_PREFIX)/usr/include/libdrm \
+        -I$(DRM_PREFIX)/usr/include/omap \
         -D_GNU_SOURCE -Wall @AM_CFLAGS@
 VPATH = ../../../packages/ti/ipc/tests
 
@@ -44,7 +48,7 @@ VPATH = ../../../packages/ti/ipc/tests
 # the program to build (the names of the final binaries)
 bin_PROGRAMS = ping_rpmsg MessageQApp  MessageQBench MessageQMulti \
                 NameServerApp
-               
+
 
 if OMAP54XX_SMP
 # Add platform specific bin application's here
@@ -53,6 +57,13 @@ if KDIR
   bin_PROGRAMS += mmrpc_test
 endif
 else
+if DRA7XX
+# Add platform specific bin application's here
+  bin_PROGRAMS +=
+if KDIR
+  bin_PROGRAMS += mmrpc_test
+endif
+else
 if OMAPL138
 # Add platform specific bin application's here
   bin_PROGRAMS +=
@@ -64,11 +75,15 @@ if TCI6614
 # Add platform specific bin application's here
   bin_PROGRAMS +=
 else
+if TCI6636
+# Add platform specific bin application's here
+  bin_PROGRAMS +=
+else
 if TCI6638
 # Add platform specific bin application's here
   bin_PROGRAMS +=
 else
-# Add platform independent apps here or above in bin_PROGRMAS
+# Add platform independent apps here or above in bin_PROGRAMS
 if CMEM
   bin_PROGRAMS += nano_test
 endif
@@ -79,6 +94,8 @@ endif
 endif
 endif
 endif
+endif
+endif
 
 common_sources = \
                 $(top_srcdir)/linux/include/ti/ipc/Std.h \
@@ -88,7 +105,7 @@ common_sources = \
 nameServer_common_sources = \
                 $(top_srcdir)/linux/include/ti/ipc/Std.h \
                 $(top_srcdir)/linux/include/ladclient.h \
-                $(top_srcdir)/linux/include/_NameServer.h \
+                $(top_srcdir)/hlos_common/include/_NameServer.h \
                 $(top_srcdir)/packages/ti/ipc/NameServer.h \
                 NameServerApp.c
 
@@ -116,13 +133,16 @@ NameServerApp_SOURCES = $(nameServer_common_sources)
 nano_test_SOURCES = $(common_sources) nano_test.c
 
 common_libraries = -lpthread $(top_builddir)/linux/src/api/libtiipc.la \
-                $(top_builddir)/linux/src/utils/libtiipcutils.la
+                $(top_builddir)/linux/src/utils/libtiipcutils.la \
+                $(DRM_PREFIX)/usr/lib/libdrm.la \
+                $(DRM_PREFIX)/usr/lib/libdrm_omap.la
 
 # the additional libraries to link ping_rpmsg
 ping_rpmsg_LDADD = -lrt
 
 # the additional libraries to link mmrpc_test
-mmrpc_test_LDADD = $(top_builddir)/linux/src/mm/libmmrpc.la
+mmrpc_test_LDADD = $(common_libraries) \
+                $(top_builddir)/linux/src/mm/libmmrpc.la
 
 # the additional libraries needed to link MessageQApp
 MessageQApp_LDADD = $(common_libraries) \
@@ -142,7 +162,7 @@ NameServerApp_LDADD = $(common_libraries) \
 
 # the additional libraries needed to link nano_test
 nano_test_LDADD = $(common_libraries) \
-                $(CMEM_INSTALL_DIR)/packages/ti/sdo/linuxutils/cmem/lib/cmem.a470MV \
+                $(CMEM_INSTALL_DIR)/src/cmem/api/.libs/libticmem.a \
                 $(AM_LDFLAGS)
 
 ###############################################################################