]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/tests/Makefile.am
Changes for new cmem.h location and CMEM library
[ipc/ipcdev.git] / linux / src / tests / Makefile.am
index 1c9c52ad59f4021252df648ac2dc226330bd8c24..9020e601339346dad3c08c3ad76b2beaeaf4f10d 100644 (file)
@@ -32,8 +32,9 @@
 ##
 
 # additional include paths necessary to compile the program
-AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/packages  \
-        -I$(CMEM_INSTALL_DIR)/packages -D_GNU_SOURCE -Wall @AM_CFLAGS@
+AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/hlos_common/include \
+        -I$(top_srcdir)/packages -I$(CMEM_INSTALL_DIR)/include \
+        -D_GNU_SOURCE -Wall @AM_CFLAGS@
 VPATH = ../../../packages/ti/ipc/tests
 
 ###############################################################################
@@ -43,7 +44,7 @@ VPATH = ../../../packages/ti/ipc/tests
 # the program to build (the names of the final binaries)
 bin_PROGRAMS = ping_rpmsg MessageQApp  MessageQBench MessageQMulti \
                 NameServerApp
-               
+
 
 if OMAP54XX_SMP
 # Add platform specific bin application's here
@@ -63,11 +64,15 @@ if TCI6614
 # Add platform specific bin application's here
   bin_PROGRAMS +=
 else
+if TCI6636
+# Add platform specific bin application's here
+  bin_PROGRAMS +=
+else
 if TCI6638
 # Add platform specific bin application's here
   bin_PROGRAMS +=
 else
-# Add platform independent apps here or above in bin_PROGRMAS
+# Add platform independent apps here or above in bin_PROGRAMS
 if CMEM
   bin_PROGRAMS += nano_test
 endif
@@ -78,6 +83,7 @@ endif
 endif
 endif
 endif
+endif
 
 common_sources = \
                 $(top_srcdir)/linux/include/ti/ipc/Std.h \
@@ -87,7 +93,7 @@ common_sources = \
 nameServer_common_sources = \
                 $(top_srcdir)/linux/include/ti/ipc/Std.h \
                 $(top_srcdir)/linux/include/ladclient.h \
-                $(top_srcdir)/linux/include/_NameServer.h \
+                $(top_srcdir)/hlos_common/include/_NameServer.h \
                 $(top_srcdir)/packages/ti/ipc/NameServer.h \
                 NameServerApp.c
 
@@ -121,7 +127,8 @@ common_libraries = -lpthread $(top_builddir)/linux/src/api/libtiipc.la \
 ping_rpmsg_LDADD = -lrt
 
 # the additional libraries to link mmrpc_test
-mmrpc_test_LDADD = $(top_builddir)/linux/src/mm/libmmrpc.la
+mmrpc_test_LDADD = $(common_libraries) \
+                $(top_builddir)/linux/src/mm/libmmrpc.la
 
 # the additional libraries needed to link MessageQApp
 MessageQApp_LDADD = $(common_libraries) \
@@ -141,7 +148,7 @@ NameServerApp_LDADD = $(common_libraries) \
 
 # the additional libraries needed to link nano_test
 nano_test_LDADD = $(common_libraries) \
-                $(CMEM_INSTALL_DIR)/packages/ti/sdo/linuxutils/cmem/lib/cmem.a470MV \
+                $(CMEM_INSTALL_DIR)/src/cmem/api/.libs/libticmem.a \
                 $(AM_LDFLAGS)
 
 ###############################################################################