OMAP5: Fix package dependency which could result in link failure
authorChris Ring <cring@ti.com>
Fri, 15 Mar 2013 17:42:29 +0000 (10:42 -0700)
committerChris Ring <cring@ti.com>
Fri, 15 Mar 2013 17:42:29 +0000 (10:42 -0700)
commit07bbdde0e941997416cc5689546655c50aaed632
tree1a4c63321f13f4e11fe574bf3ff1633f62c1a51b
parentd2a37668079e87e00b2a8ee8e29eaedde6729d40
OMAP5: Fix package dependency which could result in link failure

The ti.ipc.srvmgr.omx pkg currently only supports OMAP5, and currently has
a dependency on the ti.ipc.family.omap54xx.  This dependency needs to be
expressed so XDC's config-generated linker.cmd file orders the libraries
correctly.  This commit adds the necessary dependency.

Found when bringing up the C64T test executables.  Never reported when
building only for OMAP5's IPU, but the link failure is possible there, too.
packages/ti/srvmgr/omx/package.xs