Linux: Update user AF_RPMSG define for 4.7+ kernels