]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - keystone-rtos/edma3_lld.git/blobdiff - packages/component.mk
Misra C fixes:
[keystone-rtos/edma3_lld.git] / packages / component.mk
index b02322e59671ffa61ded368882f25801783c37df..450ca486d8d04c97766d141bddb7bbb0f14dc192 100755 (executable)
@@ -47,12 +47,17 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
                           edma3_drv_tci6616-sim_66_example edma3_drv_tci6616-sim_66_be_example  \
                           edma3_drv_tci6614-sim_66_example edma3_drv_tci6614-sim_66_be_example  \
                           edma3_drv_c6657-sim_66_example edma3_drv_c6657-sim_66_be_example  \
-                          edma3_drv_tci6634-sim_66_example edma3_drv_tci6634-sim_66_be_example  \
+                          edma3_drv_tci6638k2k-sim_66_example edma3_drv_tci6638k2k-sim_66_be_example  \
                           edma3_drv_c6670-evm_66_example edma3_drv_c6670-evm_66_be_example  \
                           edma3_drv_c6678-evm_66_example edma3_drv_c6678-evm_66_be_example  \
                           edma3_drv_tci6614-evm_66_example edma3_drv_tci6614-evm_66_be_example  \
                           edma3_drv_c6657-evm_66_example edma3_drv_c6657-evm_66_be_example  \
-                          edma3_drv_tci6634-evm_66_example edma3_drv_tci6634-evm_66_be_example  \
+                          edma3_drv_c66ak2e-evm_66_example edma3_drv_c66ak2e-evm_66_be_example  \
+                          edma3_drv_tci6638k2k-evm_66_example edma3_drv_tci6638k2k-evm_66_be_example  \
+                          edma3_drv_tci6630k2l-evm_66_example edma3_drv_tci6630k2l-evm_66_be_example  \
+                          edma3_drv_tci6636k2h-evm_66_example edma3_drv_tci6636k2h-evm_66_be_example  \
+                          edma3_drv_tci6638k2k-evm_a15_example \
+                          edma3_drv_tci6636k2h-evm_a15_example \
                           edma3_drv_omapl138-evm_arm9_example edma3_drv_omap4-evm_64t_example
 
 # List of libraries
@@ -60,26 +65,54 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
 
 
 ifeq ($(PLATFORM),)
-PLATFORM = ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c6657-sim tci6634-evm tci6634-sim
+PLATFORM = dra72x-evm tda3xx-evm tda2xx-evm ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c66ak2e-evm c6657-sim tci6638k2k-evm tci6630k2l-evm tci6638k2k-sim tci6636k2h-evm
 endif
 
 ifeq ($(TARGET),)
-TARGET = 674 m3 a8 64p 66
-edma3_lld_LIBS_ALL = edma3_lld_rm_generic
+TARGET = 674 m3 a8 64p 66 m4 a15 eve
+#edma3_lld_LIBS_ALL = edma3_lld_rm_generic
 endif
 
+tda2xx-evm_supported_targets = m4 a15 66 eve
+tda2xx-evm_m4_cores = m4
+tda2xx-evm_a15_cores = a15host
+tda2xx-evm_66_cores = c6xdsp
+tda2xx-evm_eve_cores = eve
+tda2xx-evm_m4_format_support = ELF
+tda2xx-evm_a15_format_support = ELF
+tda2xx-evm_66_format_support = ELF
+tda2xx-evm_eve_format_support = ELF
+#tda2xx-evm_profiles = debug release
+tda2xx-evm_m4_addn_params = "IPUCORE=1" "IPUCORE=0"
+
+tda3xx-evm_supported_targets = m4 66 eve
+tda3xx-evm_m4_cores = m4
+tda3xx-evm_66_cores = c6xdsp
+tda3xx-evm_eve_cores = eve
+tda3xx-evm_m4_format_support = ELF
+tda3xx-evm_66_format_support = ELF
+tda3xx-evm_eve_format_support = ELF
+
+dra72x-evm_supported_targets = a15 m4 66
+dra72x-evm_a15_cores = a15host
+dra72x-evm_m4_cores = m4
+dra72x-evm_66_cores = c6xdsp
+dra72x-evm_a15_format_support = ELF
+dra72x-evm_m4_format_support = ELF
+dra72x-evm_66_format_support = ELF
+
 #Prepare library list to build from the PLATFORM and TARGET
 ifeq ($(PLATFORM),generic)
 edma3_lld_LIBS_ALL = edma3_lld_rm_generic
 else
-edma3_lld_LIBS_ALL += $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_lld_$(plat)_$(targ)_libs))
+edma3_lld_LIBS_ALL += edma3_lld_lib_target $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_lld_$(plat)_$(targ)_libs))
 endif
 
 #Prepare Example list from PLATFORM and TARGET
 ifeq ($(ENDIAN),big)
 edma3_lld_EXAMPLES_LIST = $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_drv_$(plat)_$(targ)_be_example))
 else
-edma3_lld_EXAMPLES_LIST = $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_drv_$(plat)_$(targ)_example))
+edma3_lld_EXAMPLES_LIST = edma3_drv_example_target $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_drv_$(plat)_$(targ)_example))
 endif
 
 
@@ -190,11 +223,11 @@ edma3_drv_c6657-sim_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66
 edma3_drv_c6657-sim_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/simC6657BE
 edma3_drv_c6657-sim_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6657-sim_66_be_example_EXAMPLES_RELPATH)
 
-edma3_drv_tci6634-sim_66_example_EXAMPLES_RELPATH = examples/edma3_driver/simTCI6634
-edma3_drv_tci6634-sim_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6634-sim_66_example_EXAMPLES_RELPATH)
+edma3_drv_tci6638k2k-sim_66_example_EXAMPLES_RELPATH = examples/edma3_driver/simKepler
+edma3_drv_tci6638k2k-sim_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-sim_66_example_EXAMPLES_RELPATH)
 
-edma3_drv_tci6634-sim_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/simTCI6634BE
-edma3_drv_tci6634-sim_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6634-sim_66_be_example_EXAMPLES_RELPATH)
+edma3_drv_tci6638k2k-sim_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/simKeplerBE
+edma3_drv_tci6638k2k-sim_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-sim_66_be_example_EXAMPLES_RELPATH)
 
 edma3_drv_c6670-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evm6670
 edma3_drv_c6670-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6670-evm_66_example_EXAMPLES_RELPATH)
@@ -208,21 +241,77 @@ edma3_drv_c6678-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66
 edma3_drv_c6678-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evm6678BE
 edma3_drv_c6678-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6678-evm_66_be_example_EXAMPLES_RELPATH)
 
+edma3_drv_c66ak2e-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmC66AK2E
+edma3_drv_c66ak2e-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66ak2e-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_c66ak2e-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmC66AK2EBE
+edma3_drv_c66ak2e-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66ak2e-evm_66_be_example_EXAMPLES_RELPATH)
+
 edma3_drv_tci6614-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6614
 edma3_drv_tci6614-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6614-evm_66_example_EXAMPLES_RELPATH)
 
 edma3_drv_tci6614-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6614BE
 edma3_drv_tci6614-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6614-evm_66_be_example_EXAMPLES_RELPATH)
 
-edma3_drv_c6657-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmC6657
+edma3_drv_c6657-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evm6657
 edma3_drv_c6657-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6657-evm_66_example_EXAMPLES_RELPATH)
 
-edma3_drv_c6657-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmC6657BE
+edma3_drv_c6657-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evm6657BE
 edma3_drv_c6657-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6657-evm_66_be_example_EXAMPLES_RELPATH)
 
-edma3_drv_tci6634-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6634
-edma3_drv_tci6634-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6634-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_tci6638k2k-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6638K2K
+edma3_drv_tci6638k2k-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6638k2k-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6638K2KBE
+edma3_drv_tci6638k2k-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-evm_66_be_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6630k2l-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6630K2L
+edma3_drv_tci6630k2l-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6630k2l-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6630K2LBE
+edma3_drv_tci6630k2l-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_66_be_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2H
+edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2HBE
+edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_M4
+edma3_drv_tda2xx-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda2xx-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_A15
+edma3_drv_tda2xx-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda2xx-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx
+edma3_drv_tda2xx-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6636K2H
+edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6638K2K
+edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmC66AK2E
+edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6630K2L
+edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_EVE
+edma3_drv_tda2xx-evm_eve_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda3xx-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTDA3xx_DSP
+edma3_drv_tda3xx-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda3xx-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_tda3xx-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTDA3xx_M4
+edma3_drv_tda3xx-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda3xx-evm_m4_example_EXAMPLES_RELPATH)
+edma3_drv_tda3xx-evm_eve_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTDA3xx_EVE
+edma3_drv_tda3xx-evm_eve_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda3xx-evm_eve_example_EXAMPLES_RELPATH)
+
+edma3_drv_dra72x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_a15
+edma3_drv_dra72x-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_dra72x-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_DSP
+edma3_drv_dra72x-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_dra72x-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_M4
+edma3_drv_dra72x-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_m4_example_EXAMPLES_RELPATH)
 
-edma3_drv_tci6634-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6634BE
-edma3_drv_tci6634-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6634-evm_66_be_example_EXAMPLES_RELPATH)
 # Nothing beyond this point