]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - keystone-rtos/edma3_lld.git/blobdiff - packages/component.mk
PRSDK-5267 Add support to enable SMP mode
[keystone-rtos/edma3_lld.git] / packages / component.mk
index 06397fbd1048722c560a1256f92ce372d8f37027..7bba236df801f704d47cb6a3fbfb3b70bba6ade8 100755 (executable)
 #                        module. This can be multiple directories (space separated)
 # <mod>_PKG_LIST       - Names of the modules (and sub-modules) that are a part
 #                        part of this module, including itself.
-# <mod>_PLATFORM_DEPENDENCY - "yes": means the code for this module depends on 
+# <mod>_PLATFORM_DEPENDENCY - "yes": means the code for this module depends on
 #                             platform and the compiled obj/lib has to be kept
 #                             under <platform> directory
 #                             "no" or "" or if this variable is not defined: means
 #                             this module has no platform dependent code and hence
 #                             the obj/libs are not kept under <platform> dir.
-# <mod>_CORE_DEPENDENCY     - "yes": means the code for this module depends on 
+# <mod>_CORE_DEPENDENCY     - "yes": means the code for this module depends on
 #                             core and the compiled obj/lib has to be kept
 #                             under <core> directory
 #                             "no" or "" or if this variable is not defined: means
@@ -52,10 +52,16 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
                           edma3_drv_c6678-evm_66_example edma3_drv_c6678-evm_66_be_example  \
                           edma3_drv_tci6614-evm_66_example edma3_drv_tci6614-evm_66_be_example  \
                           edma3_drv_c6657-evm_66_example edma3_drv_c6657-evm_66_be_example  \
+                          edma3_drv_c66ak2e-evm_66_example edma3_drv_c66ak2e-evm_66_be_example  \
                           edma3_drv_tci6638k2k-evm_66_example edma3_drv_tci6638k2k-evm_66_be_example  \
+                          edma3_drv_tci6630k2l-evm_66_example edma3_drv_tci6630k2l-evm_66_be_example  \
                           edma3_drv_tci6636k2h-evm_66_example edma3_drv_tci6636k2h-evm_66_be_example  \
+                          edma3_drv_tci66ak2g02-evm_66_example edma3_drv_tci66ak2g02-evm_66_be_example  \
                           edma3_drv_tci6638k2k-evm_a15_example \
                           edma3_drv_tci6636k2h-evm_a15_example \
+                          edma3_drv_tci66ak2g02-evm_a15_example \
+                          edma3_drv_am335x-evm_a8_example \
+                          edma3_drv_am437x-evm_a9_example \
                           edma3_drv_omapl138-evm_arm9_example edma3_drv_omap4-evm_64t_example
 
 # List of libraries
@@ -63,26 +69,78 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
 
 
 ifeq ($(PLATFORM),)
-PLATFORM = tda2xx-evm ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c6657-sim tci6638k2k-evm tci6638k2k-sim tci6636k2h-evm
+PLATFORM = am572x-evm am571x-evm dra72x-evm tda2ex-evm tda3xx-evm tda2xx-evm am335x-evm am437x-evm ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c66ak2e-evm c6657-sim tci6638k2k-evm tci6630k2l-evm tci6638k2k-sim tci6636k2h-evm tci66ak2g02-evm
 endif
 
 ifeq ($(TARGET),)
-TARGET = 674 m3 a8 64p 66 m4 a15
+TARGET = 674 m3 a8 64p 66 m4 a15 eve
 edma3_lld_LIBS_ALL = edma3_lld_rm_generic
 endif
 
+tda2xx-evm_supported_targets = m4 a15 66 eve
+tda2xx-evm_m4_cores = m4
+tda2xx-evm_a15_cores = a15host
+tda2xx-evm_66_cores = c6xdsp
+tda2xx-evm_eve_cores = eve
+tda2xx-evm_m4_format_support = ELF
+tda2xx-evm_a15_format_support = ELF
+tda2xx-evm_66_format_support = ELF
+tda2xx-evm_eve_format_support = ELF
+#tda2xx-evm_profiles = debug release
+tda2xx-evm_m4_addn_params = "IPUCORE=1" "IPUCORE=0"
+
+tda3xx-evm_supported_targets = m4 66 eve
+tda3xx-evm_m4_cores = m4
+tda3xx-evm_66_cores = c6xdsp
+tda3xx-evm_eve_cores = eve
+tda3xx-evm_m4_format_support = ELF
+tda3xx-evm_66_format_support = ELF
+tda3xx-evm_eve_format_support = ELF
+
+dra72x-evm_supported_targets = a15 m4 66
+dra72x-evm_a15_cores = a15host
+dra72x-evm_m4_cores = m4
+dra72x-evm_66_cores = c6xdsp
+dra72x-evm_a15_format_support = ELF
+dra72x-evm_m4_format_support = ELF
+dra72x-evm_66_format_support = ELF
+
+tda2ex-evm_supported_targets = a15 m4 66
+tda2ex-evm_a15_cores = a15host
+tda2ex-evm_m4_cores = m4
+tda2ex-evm_66_cores = c6xdsp
+tda2ex-evm_a15_format_support = ELF
+tda2ex-evm_m4_format_support = ELF
+tda2ex-evm_66_format_support = ELF
+
+am572x-evm_supported_targets = a15 m4 66
+am572x-evm_a15_cores = a15host
+am572x-evm_m4_cores = m4
+am572x-evm_66_cores = c6xdsp
+am572x-evm_a15_format_support = ELF
+am572x-evm_m4_format_support = ELF
+am572x-evm_66_format_support = ELF
+
+am571x-evm_supported_targets = a15 m4 66
+am571x-evm_a15_cores = a15host
+am571x-evm_m4_cores = m4
+am571x-evm_66_cores = c6xdsp
+am571x-evm_a15_format_support = ELF
+am571x-evm_m4_format_support = ELF
+am571x-evm_66_format_support = ELF
+
 #Prepare library list to build from the PLATFORM and TARGET
 ifeq ($(PLATFORM),generic)
 edma3_lld_LIBS_ALL = edma3_lld_rm_generic
 else
-edma3_lld_LIBS_ALL += $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_lld_$(plat)_$(targ)_libs))
+edma3_lld_LIBS_ALL += edma3_lld_lib_target $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_lld_$(plat)_$(targ)_libs))
 endif
 
 #Prepare Example list from PLATFORM and TARGET
 ifeq ($(ENDIAN),big)
 edma3_lld_EXAMPLES_LIST = $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_drv_$(plat)_$(targ)_be_example))
 else
-edma3_lld_EXAMPLES_LIST = $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_drv_$(plat)_$(targ)_example))
+edma3_lld_EXAMPLES_LIST = edma3_drv_example_target $(foreach plat, $(PLATFORM),$(foreach targ,$(TARGET),edma3_drv_$(plat)_$(targ)_example))
 endif
 
 
@@ -127,12 +185,18 @@ edma3_drv_c6748-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6
 edma3_drv_da830-evm_674_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDA830
 edma3_drv_da830-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_da830-evm_674_example_EXAMPLES_RELPATH)
 
+edma3_drv_omapl137-evm_674_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL137
+edma3_drv_omapl137-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl137-evm_674_example_EXAMPLES_RELPATH)
+
 edma3_drv_omapl138-evm_674_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL138
 edma3_drv_omapl138-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl138-evm_674_example_EXAMPLES_RELPATH)
 
 edma3_drv_omap4-evm_64t_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAP4
 edma3_drv_omap4-evm_64t_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omap4-evm_64t_example_EXAMPLES_RELPATH)
 
+edma3_drv_omapl137-evm_arm9_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL137_ARM
+edma3_drv_omapl137-evm_arm9_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl137-evm_arm9_example_EXAMPLES_RELPATH)
+
 edma3_drv_omapl138-evm_arm9_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL138_ARM
 edma3_drv_omapl138-evm_arm9_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl138-evm_arm9_example_EXAMPLES_RELPATH)
 
@@ -211,6 +275,11 @@ edma3_drv_c6678-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66
 edma3_drv_c6678-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evm6678BE
 edma3_drv_c6678-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6678-evm_66_be_example_EXAMPLES_RELPATH)
 
+edma3_drv_c66ak2e-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmC66AK2E
+edma3_drv_c66ak2e-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66ak2e-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_c66ak2e-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmC66AK2EBE
+edma3_drv_c66ak2e-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66ak2e-evm_66_be_example_EXAMPLES_RELPATH)
+
 edma3_drv_tci6614-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6614
 edma3_drv_tci6614-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6614-evm_66_example_EXAMPLES_RELPATH)
 
@@ -229,12 +298,21 @@ edma3_drv_tci6638k2k-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_dr
 edma3_drv_tci6638k2k-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6638K2KBE
 edma3_drv_tci6638k2k-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-evm_66_be_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci6630k2l-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6630K2L
+edma3_drv_tci6630k2l-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6630k2l-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6630K2LBE
+edma3_drv_tci6630k2l-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_66_be_example_EXAMPLES_RELPATH)
+
 edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2H
 edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_RELPATH)
 
 edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2HBE
 edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636AK2G02BE
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH)
+
 edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_M4
 edma3_drv_tda2xx-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH)
 
@@ -247,7 +325,73 @@ edma3_drv_tda2xx-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_td
 edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6636K2H
 edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci6636k2h-evm_a15_example_bios_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2H_A15
+edma3_drv_tci6636k2h-evm_a15_example_bios_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_a15_example_bios_EXAMPLES_RELPATH)
+
 edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6638K2K
 edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_RELPATH)
 
+edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmC66AK2E
+edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6630K2L
+edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_EVE
+edma3_drv_tda2xx-evm_eve_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda3xx-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTDA3xx_DSP
+edma3_drv_tda3xx-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda3xx-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_tda3xx-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTDA3xx_M4
+edma3_drv_tda3xx-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda3xx-evm_m4_example_EXAMPLES_RELPATH)
+edma3_drv_tda3xx-evm_eve_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTDA3xx_EVE
+edma3_drv_tda3xx-evm_eve_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda3xx-evm_eve_example_EXAMPLES_RELPATH)
+
+edma3_drv_dra72x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_A15
+edma3_drv_dra72x-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_dra72x-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_DSP
+edma3_drv_dra72x-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_dra72x-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_M4
+edma3_drv_dra72x-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_m4_example_EXAMPLES_RELPATH)
+
+edma3_drv_tda2ex-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_A15
+edma3_drv_tda2ex-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2ex-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_tda2ex-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_DSP
+edma3_drv_tda2ex-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2ex-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_tda2ex-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_M4
+edma3_drv_tda2ex-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2ex-evm_m4_example_EXAMPLES_RELPATH)
+
+edma3_drv_am572x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM572x_A15
+edma3_drv_am572x-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am572x-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_am572x-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM572x_DSP
+edma3_drv_am572x-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am572x-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_am572x-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM572x_M4
+edma3_drv_am572x-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am572x-evm_m4_example_EXAMPLES_RELPATH)
+
+
+edma3_drv_am571x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM571x_A15
+edma3_drv_am571x-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am571x-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_am571x-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM571x_DSP
+edma3_drv_am571x-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am571x-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_am571x-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM571x_M4
+edma3_drv_am571x-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am571x-evm_m4_example_EXAMPLES_RELPATH)
+
+edma3_drv_am335x-evm_a8_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM335x_A8
+edma3_drv_am335x-evm_a8_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am335x-evm_a8_example_EXAMPLES_RELPATH)
+
+edma3_drv_am437x-evm_a9_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM437x_A9
+edma3_drv_am437x-evm_a9_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am437x-evm_a9_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI66AK2G02BE
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH)
+
 # Nothing beyond this point