]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - keystone-rtos/edma3_lld.git/blobdiff - packages/component.mk
updated lib path for gcc compiler
[keystone-rtos/edma3_lld.git] / packages / component.mk
index dce1439d0b715cbfcd883c79450ca0dd7ab9b402..7bba236df801f704d47cb6a3fbfb3b70bba6ade8 100755 (executable)
@@ -56,8 +56,10 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
                           edma3_drv_tci6638k2k-evm_66_example edma3_drv_tci6638k2k-evm_66_be_example  \
                           edma3_drv_tci6630k2l-evm_66_example edma3_drv_tci6630k2l-evm_66_be_example  \
                           edma3_drv_tci6636k2h-evm_66_example edma3_drv_tci6636k2h-evm_66_be_example  \
+                          edma3_drv_tci66ak2g02-evm_66_example edma3_drv_tci66ak2g02-evm_66_be_example  \
                           edma3_drv_tci6638k2k-evm_a15_example \
                           edma3_drv_tci6636k2h-evm_a15_example \
+                          edma3_drv_tci66ak2g02-evm_a15_example \
                           edma3_drv_am335x-evm_a8_example \
                           edma3_drv_am437x-evm_a9_example \
                           edma3_drv_omapl138-evm_arm9_example edma3_drv_omap4-evm_64t_example
@@ -67,7 +69,7 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
 
 
 ifeq ($(PLATFORM),)
-PLATFORM = am572x-evm am571x-evm dra72x-evm tda2ex-evm tda3xx-evm tda2xx-evm am335x-evm am437x-evm ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c66ak2e-evm c6657-sim tci6638k2k-evm tci6630k2l-evm tci6638k2k-sim tci6636k2h-evm
+PLATFORM = am572x-evm am571x-evm dra72x-evm tda2ex-evm tda3xx-evm tda2xx-evm am335x-evm am437x-evm ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c66ak2e-evm c6657-sim tci6638k2k-evm tci6630k2l-evm tci6638k2k-sim tci6636k2h-evm tci66ak2g02-evm
 endif
 
 ifeq ($(TARGET),)
@@ -127,12 +129,6 @@ am571x-evm_a15_format_support = ELF
 am571x-evm_m4_format_support = ELF
 am571x-evm_66_format_support = ELF
 
-tci6636k2h-evm_supported_targets = a15 66
-tci6636k2h-evm_a15_cores = a15host
-tci6636k2h-evm_66_cores = c6xdsp
-tci6636k2h-evm_a15_format_support = ELF
-tci6636k2h-evm_66_format_support = ELF
-
 #Prepare library list to build from the PLATFORM and TARGET
 ifeq ($(PLATFORM),generic)
 edma3_lld_LIBS_ALL = edma3_lld_rm_generic
@@ -189,12 +185,18 @@ edma3_drv_c6748-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_c6
 edma3_drv_da830-evm_674_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDA830
 edma3_drv_da830-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_da830-evm_674_example_EXAMPLES_RELPATH)
 
+edma3_drv_omapl137-evm_674_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL137
+edma3_drv_omapl137-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl137-evm_674_example_EXAMPLES_RELPATH)
+
 edma3_drv_omapl138-evm_674_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL138
 edma3_drv_omapl138-evm_674_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl138-evm_674_example_EXAMPLES_RELPATH)
 
 edma3_drv_omap4-evm_64t_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAP4
 edma3_drv_omap4-evm_64t_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omap4-evm_64t_example_EXAMPLES_RELPATH)
 
+edma3_drv_omapl137-evm_arm9_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL137_ARM
+edma3_drv_omapl137-evm_arm9_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl137-evm_arm9_example_EXAMPLES_RELPATH)
+
 edma3_drv_omapl138-evm_arm9_example_EXAMPLES_RELPATH = examples/edma3_driver/evmOMAPL138_ARM
 edma3_drv_omapl138-evm_arm9_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_omapl138-evm_arm9_example_EXAMPLES_RELPATH)
 
@@ -308,6 +310,9 @@ edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_dr
 edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2HBE
 edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636AK2G02BE
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH)
+
 edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_M4
 edma3_drv_tda2xx-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH)
 
@@ -332,6 +337,9 @@ edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_
 edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6630K2L
 edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH)
+
 edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_EVE
 edma3_drv_tda2xx-evm_eve_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH)
 
@@ -377,4 +385,13 @@ edma3_drv_am335x-evm_a8_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am
 edma3_drv_am437x-evm_a9_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM437x_A9
 edma3_drv_am437x-evm_a9_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am437x-evm_a9_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI66AK2G02BE
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH)
+
 # Nothing beyond this point