]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - keystone-rtos/edma3_lld.git/blobdiff - packages/component.mk
makefiles: updated gcc arm none to 4.9.3
[keystone-rtos/edma3_lld.git] / packages / component.mk
index 450ca486d8d04c97766d141bddb7bbb0f14dc192..bed5f2a41db81b59c3483bd22824fd77e7070fc9 100755 (executable)
 #                        module. This can be multiple directories (space separated)
 # <mod>_PKG_LIST       - Names of the modules (and sub-modules) that are a part
 #                        part of this module, including itself.
-# <mod>_PLATFORM_DEPENDENCY - "yes": means the code for this module depends on 
+# <mod>_PLATFORM_DEPENDENCY - "yes": means the code for this module depends on
 #                             platform and the compiled obj/lib has to be kept
 #                             under <platform> directory
 #                             "no" or "" or if this variable is not defined: means
 #                             this module has no platform dependent code and hence
 #                             the obj/libs are not kept under <platform> dir.
-# <mod>_CORE_DEPENDENCY     - "yes": means the code for this module depends on 
+# <mod>_CORE_DEPENDENCY     - "yes": means the code for this module depends on
 #                             core and the compiled obj/lib has to be kept
 #                             under <core> directory
 #                             "no" or "" or if this variable is not defined: means
@@ -56,8 +56,12 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
                           edma3_drv_tci6638k2k-evm_66_example edma3_drv_tci6638k2k-evm_66_be_example  \
                           edma3_drv_tci6630k2l-evm_66_example edma3_drv_tci6630k2l-evm_66_be_example  \
                           edma3_drv_tci6636k2h-evm_66_example edma3_drv_tci6636k2h-evm_66_be_example  \
+                          edma3_drv_tci66ak2g02-evm_66_example edma3_drv_tci66ak2g02-evm_66_be_example  \
                           edma3_drv_tci6638k2k-evm_a15_example \
                           edma3_drv_tci6636k2h-evm_a15_example \
+                          edma3_drv_tci66ak2g02-evm_a15_example \
+                          edma3_drv_am335x-evm_a8_example \
+                          edma3_drv_am437x-evm_a9_example \
                           edma3_drv_omapl138-evm_arm9_example edma3_drv_omap4-evm_64t_example
 
 # List of libraries
@@ -65,12 +69,12 @@ edma3_lld_EXAMPLES_LIST = edma3_drv_ti816x-evm_m3_example edma3_drv_c6472-evm_64
 
 
 ifeq ($(PLATFORM),)
-PLATFORM = dra72x-evm tda3xx-evm tda2xx-evm ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c66ak2e-evm c6657-sim tci6638k2k-evm tci6630k2l-evm tci6638k2k-sim tci6636k2h-evm
+PLATFORM = am572x-evm am571x-evm dra72x-evm tda2ex-evm tda3xx-evm tda2xx-evm am335x-evm am437x-evm ti816x-evm ti814x-evm c6a811x-evm c6472-evm c6670-evm c6678-evm c6748-evm da830-evm omapl138-evm tci6486-evm tci6608-sim tci6616-sim tci6614-evm tci6614-sim c6657-evm c66ak2e-evm c6657-sim tci6638k2k-evm tci6630k2l-evm tci6638k2k-sim tci6636k2h-evm tci66ak2g02-evm
 endif
 
 ifeq ($(TARGET),)
 TARGET = 674 m3 a8 64p 66 m4 a15 eve
-#edma3_lld_LIBS_ALL = edma3_lld_rm_generic
+edma3_lld_LIBS_ALL = edma3_lld_rm_generic
 endif
 
 tda2xx-evm_supported_targets = m4 a15 66 eve
@@ -101,6 +105,30 @@ dra72x-evm_a15_format_support = ELF
 dra72x-evm_m4_format_support = ELF
 dra72x-evm_66_format_support = ELF
 
+tda2ex-evm_supported_targets = a15 m4 66
+tda2ex-evm_a15_cores = a15host
+tda2ex-evm_m4_cores = m4
+tda2ex-evm_66_cores = c6xdsp
+tda2ex-evm_a15_format_support = ELF
+tda2ex-evm_m4_format_support = ELF
+tda2ex-evm_66_format_support = ELF
+
+am572x-evm_supported_targets = a15 m4 66
+am572x-evm_a15_cores = a15host
+am572x-evm_m4_cores = m4
+am572x-evm_66_cores = c6xdsp
+am572x-evm_a15_format_support = ELF
+am572x-evm_m4_format_support = ELF
+am572x-evm_66_format_support = ELF
+
+am571x-evm_supported_targets = a15 m4 66
+am571x-evm_a15_cores = a15host
+am571x-evm_m4_cores = m4
+am571x-evm_66_cores = c6xdsp
+am571x-evm_a15_format_support = ELF
+am571x-evm_m4_format_support = ELF
+am571x-evm_66_format_support = ELF
+
 #Prepare library list to build from the PLATFORM and TARGET
 ifeq ($(PLATFORM),generic)
 edma3_lld_LIBS_ALL = edma3_lld_rm_generic
@@ -276,6 +304,9 @@ edma3_drv_tci6636k2h-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_dr
 edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2HBE
 edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_66_be_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636AK2G02BE
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH)
+
 edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_M4
 edma3_drv_tda2xx-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_m4_example_EXAMPLES_RELPATH)
 
@@ -288,6 +319,9 @@ edma3_drv_tda2xx-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_td
 edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6636K2H
 edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_a15_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci6636k2h-evm_a15_example_bios_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI6636K2H_A15
+edma3_drv_tci6636k2h-evm_a15_example_bios_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6636k2h-evm_a15_example_bios_EXAMPLES_RELPATH)
+
 edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6638K2K
 edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6638k2k-evm_a15_example_EXAMPLES_RELPATH)
 
@@ -297,6 +331,9 @@ edma3_drv_c66ak2e-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_
 edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI6630K2L
 edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci6630k2l-evm_a15_example_EXAMPLES_RELPATH)
 
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH)
+
 edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH = examples/edma3_driver/evmtda2xx_EVE
 edma3_drv_tda2xx-evm_eve_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2xx-evm_eve_example_EXAMPLES_RELPATH)
 
@@ -307,11 +344,48 @@ edma3_drv_tda3xx-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_td
 edma3_drv_tda3xx-evm_eve_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTDA3xx_EVE
 edma3_drv_tda3xx-evm_eve_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda3xx-evm_eve_example_EXAMPLES_RELPATH)
 
-edma3_drv_dra72x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_a15
+edma3_drv_dra72x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_A15
 edma3_drv_dra72x-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_a15_example_EXAMPLES_RELPATH)
 edma3_drv_dra72x-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_DSP
 edma3_drv_dra72x-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_66_example_EXAMPLES_RELPATH)
 edma3_drv_dra72x-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_M4
 edma3_drv_dra72x-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_dra72x-evm_m4_example_EXAMPLES_RELPATH)
 
+edma3_drv_tda2ex-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_A15
+edma3_drv_tda2ex-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2ex-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_tda2ex-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_DSP
+edma3_drv_tda2ex-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2ex-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_tda2ex-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmDRA72x_M4
+edma3_drv_tda2ex-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tda2ex-evm_m4_example_EXAMPLES_RELPATH)
+
+edma3_drv_am572x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM572x_A15
+edma3_drv_am572x-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am572x-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_am572x-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM572x_DSP
+edma3_drv_am572x-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am572x-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_am572x-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM572x_M4
+edma3_drv_am572x-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am572x-evm_m4_example_EXAMPLES_RELPATH)
+
+
+edma3_drv_am571x-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM571x_A15
+edma3_drv_am571x-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am571x-evm_a15_example_EXAMPLES_RELPATH)
+edma3_drv_am571x-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM571x_DSP
+edma3_drv_am571x-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am571x-evm_66_example_EXAMPLES_RELPATH)
+edma3_drv_am571x-evm_m4_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM571x_M4
+edma3_drv_am571x-evm_m4_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am571x-evm_m4_example_EXAMPLES_RELPATH)
+
+edma3_drv_am335x-evm_a8_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM335x_A8
+edma3_drv_am335x-evm_a8_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am335x-evm_a8_example_EXAMPLES_RELPATH)
+
+edma3_drv_am437x-evm_a9_example_EXAMPLES_RELPATH = examples/edma3_driver/evmAM437x_A9
+edma3_drv_am437x-evm_a9_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_am437x-evm_a9_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH = examples/edma3_driver/evmTCI66AK2G02BE
+edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_66_be_example_EXAMPLES_RELPATH)
+
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH = examples/edma3_user_space_driver/evmTCI66AK2G02
+edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_PATH = $(edma3_lld_PATH)/$(edma3_drv_tci66ak2g02-evm_a15_example_EXAMPLES_RELPATH)
+
 # Nothing beyond this point