]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - keystone-rtos/edma3_lld.git/blobdiff - packages/ti/sdo/edma3/drv/makefile
Revert "Include rules.make file"
[keystone-rtos/edma3_lld.git] / packages / ti / sdo / edma3 / drv / makefile
index c6f5ccc228ccc196885f862d111549d3dcd4cf41..bce03aa246ac8e13815dcc33f60ca2f2a6ee9cc1 100644 (file)
@@ -5,9 +5,9 @@ MODULE_NAME = edma3_lld_drv
 SRCDIR = src
 INCDIR = . ../../../.. src
 
-# List all the external components/interfaces, whose interface header files 
+# List all the external components/interfaces, whose interface header files
 #  need to be included for this component
-INCLUDE_EXERNAL_INTERFACES = 
+INCLUDE_EXTERNAL_INTERFACES =
 
 # Common source files and CFLAGS across all platforms and cores
 SRCS_COMMON = edma3_drv_init.c edma3_drv_basic.c edma3_drv_adv.c
@@ -16,14 +16,19 @@ CFLAGS_LOCAL_COMMON = -mi10
 endif
 
 # Core/SoC/platform specific source files and CFLAGS
-# Example: 
-#   SRCS_<core/SoC/platform-name> = 
+# Example:
+#   SRCS_<core/SoC/platform-name> =
 #   CFLAGS_LOCAL_<core/SoC/platform-name> =
 
 # Include common make files
-include $(ROOTDIR)/makerules/common.mk
+ifeq ($(MAKERULEDIR), )
+#Makerule path not defined, define this and assume relative path from ROOTDIR
+  MAKERULEDIR := $(ROOTDIR)/makerules
+  export MAKERULEDIR
+endif
+include $(MAKERULEDIR)/common.mk
 
-# OBJs and libraries are built by using rule defined in rules_<target>.mk 
+# OBJs and libraries are built by using rule defined in rules_<target>.mk
 #     and need not be explicitly specified here
 
 # Nothing beyond this point