]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - keystone-rtos/edma3_lld.git/blobdiff - packages/ti/sdo/edma3/drv/sample/makefile
Removed evm prefix in SRC addition
[keystone-rtos/edma3_lld.git] / packages / ti / sdo / edma3 / drv / sample / makefile
index d1c1d63f09db56682ebca62186cf9a046bd41f2a..f11859ccb59e87f1013e1e190482c20106b14134 100755 (executable)
@@ -5,9 +5,9 @@ MODULE_NAME = edma3_lld_drv_sample
 SRCDIR = src src/platforms
 INCDIR = . ../../../../.. src
 
-# List all the external components/interfaces, whose interface header files 
+# List all the external components/interfaces, whose interface header files
 #  need to be included for this component
-INCLUDE_EXERNAL_INTERFACES = bios xdc
+INCLUDE_EXTERNAL_INTERFACES = bios xdc
 
 # Common source files and CFLAGS across all platforms and cores
 ifeq ($(CORE),c6xdsp)
@@ -20,10 +20,10 @@ CFLAGS_LOCAL_COMMON = -mi10
 endif
 
 # Core/SoC/platform specific source files and CFLAGS
-# Example: 
-#   SRCS_<core/SoC/platform-name> = 
+# Example:
+#   SRCS_<core/SoC/platform-name> =
 #   CFLAGS_LOCAL_<core/SoC/platform-name> =
-ifeq ($(CORE),c6xdsp)
+ifeq ($(CORE),$(filter $(CORE), c6xdsp c66xdsp))
 SRCS_c6472-evm = sample_c6472_cfg.c sample_c6472_int_reg.c
 SRCS_tci6486-evm = sample_tci6486_cfg.c sample_tci6486_int_reg.c
 SRCS_tci6608-sim = sample_tci6608_cfg.c sample_tci6608_int_reg.c
@@ -47,11 +47,17 @@ CFLAGS_LOCAL_ti814x-evm = -DBUILD_CENTAURUS_DSP
 SRCS_ti816x-evm = sample_ti816x_cfg.c sample_ti816x_int_reg.c
 CFLAGS_LOCAL_c6a811x-evm = -DBUILD_C6A811X_DSP
 SRCS_c6a811x-evm = sample_c6a811x_cfg.c sample_c6a811x_int_reg.c
-SRCS_tda2xx-evm = sample_tda2xx_cfg.c sample_tda2xx_int_reg.c
-CFLAGS_LOCAL_tda2xx-evm = -DBUILD_TDA2XX_DSP
+SRCS_tda2xx = sample_tda2xx_cfg.c sample_tda2xx_int_reg.c
+CFLAGS_LOCAL_tda2xx = -DBUILD_TDA2XX_DSP
+SRCS_tda3xx = sample_tda3xx_cfg.c sample_tda3xx_int_reg.c
+CFLAGS_LOCAL_tda3xx = -DBUILD_TDA3XX_DSP
+SRCS_dra72x = sample_dra72x_cfg.c sample_dra72x_int_reg.c
+CFLAGS_LOCAL_dra72x = -DBUILD_DRA72X_DSP
 else
 SRCS_omapl138-evm = sample_omapl138_arm_cfg.c sample_omapl138_arm_int_reg.c
-SRCS_tda2xx-evm = sample_tda2xx_cfg.c sample_tda2xx_arm_int_reg.c
+SRCS_tda2xx = sample_tda2xx_cfg.c sample_tda2xx_arm_int_reg.c
+SRCS_tda3xx = sample_tda3xx_cfg.c sample_tda3xx_arm_int_reg.c
+SRCS_dra72x = sample_dra72x_cfg.c sample_dra72x_arm_int_reg.c
 endif
 
 ifeq ($(CORE),a8host)
@@ -81,16 +87,21 @@ SRCS_ti814x-evm = sample_ti814x_cfg.c sample_ti814x_arm_int_reg.c
 SRCS_c6a811x-evm = sample_c6a811x_cfg.c sample_c6a811x_arm_int_reg.c
 endif
 
-ifeq ($(CORE),m4)
-CFLAGS_LOCAL_tda2xx-evm = -DBUILD_TDA2XX_IPU
+ifeq ($(CORE),$(filter $(CORE), m4 m4vpss))
+CFLAGS_LOCAL_tda2xx = -DBUILD_TDA2XX_IPU
+CFLAGS_LOCAL_tda3xx = -DBUILD_TDA3XX_IPU
+CFLAGS_LOCAL_dra72x = -DBUILD_DRA72X_IPU
 endif
 
 ifeq ($(CORE),a15host)
-CFLAGS_LOCAL_tda2xx-evm = -DBUILD_TDA2XX_MPU
+CFLAGS_LOCAL_tda2xx = -DBUILD_TDA2XX_MPU
+CFLAGS_LOCAL_dra72x = -DBUILD_DRA72X_MPU
 endif
 
 ifeq ($(CORE),eve)
-CFLAGS_LOCAL_tda2xx-evm = -DBUILD_TDA2XX_EVE
+CFLAGS_LOCAL_tda2xx = -DBUILD_TDA2XX_EVE
+CFLAGS_LOCAL_tda3xx = -DBUILD_TDA3XX_EVE
+CFLAGS_LOCAL_dra72x = -DBUILD_DRA72X_EVE
 endif
 
 SRCS_c6748-evm = sample_c6748_cfg.c sample_c6748_int_reg.c
@@ -100,9 +111,14 @@ CFLAGS_LOCAL_ti814x-evm += -DCHIP_TI814X
 CFLAGS_LOCAL_c6a811x-evm += -DCHIP_C6A811X
 
 # Include common make files
-include $(ROOTDIR)/makerules/common.mk
+ifeq ($(MAKERULEDIR), )
+#Makerule path not defined, define this and assume relative path from ROOTDIR
+  MAKERULEDIR := $(ROOTDIR)/makerules
+  export MAKERULEDIR
+endif
+include $(MAKERULEDIR)/common.mk
 
-# OBJs and libraries are built by using rule defined in rules_<target>.mk 
+# OBJs and libraries are built by using rule defined in rules_<target>.mk
 #     and need not be explicitly specified here
 
 # Nothing beyond this point