]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - keystone-rtos/edma3_lld.git/blobdiff - packages/ti/sdo/edma3/rm/makefile
TDA2ex and other core support needed for PDK
[keystone-rtos/edma3_lld.git] / packages / ti / sdo / edma3 / rm / makefile
index 985c93e14e81e6977d02ba0656a0a97b5c94d25e..855a2c95a9429dd350e8da7b58be6a010a2dc58b 100644 (file)
@@ -1,13 +1,14 @@
 # Makefile for EDMA3 LLD RM
+-include $(MAKERULEDIR)/../Rules.make
 
 MODULE_NAME = edma3_lld_rm
 
 SRCDIR = src src/configs
 INCDIR = . ../../../.. src
 
-# List all the external components/interfaces, whose interface header files 
+# List all the external components/interfaces, whose interface header files
 #  need to be included for this component
-INCLUDE_EXERNAL_INTERFACES = 
+INCLUDE_EXTERNAL_INTERFACES =
 
 # Common source files and CFLAGS across all platforms and cores
 SRCS_COMMON = edma3resmgr.c edma3_rm_gbl_data.c
@@ -28,13 +29,15 @@ endif
 ifeq ($(CORE),m3vpss)
 CFLAGS_LOCAL_c6a811x-evm = -DBUILD_C6A811X_M3VPSS
 endif
-ifeq ($(CORE),a15host)
-CFLAGS_LOCAL_tda2xx-evm = -DBUILD_TDA2XX_MPU
+ifeq ($(CORE),$(filter $(CORE), a15_0 a15host))
+ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
+CFLAGS_LOCAL_COMMON += -DBUILD_TDA2XX_MPU
+endif
 endif
 
 # Core/SoC/platform specific source files and CFLAGS
-# Example: 
-#   SRCS_<core/SoC/platform-name> = 
+# Example:
+#   SRCS_<core/SoC/platform-name> =
 #   CFLAGS_LOCAL_<core/SoC/platform-name> =
 SRCS_c6472-evm = edma3_c6472_cfg.c
 SRCS_tci6486-evm = edma3_tci6486_cfg.c
@@ -51,21 +54,31 @@ SRCS_tci6638k2k-evm = edma3_tci6638k2k_cfg.c
 SRCS_tci6636k2h-evm = edma3_tci6636k2h_cfg.c
 SRCS_tci6630k2l-evm = edma3_tci6630k2l_cfg.c
 SRCS_c66ak2e-evm = edma3_c66ak2e_cfg.c
+SRCS_tci66ak2g02-evm = edma3_tci66ak2g02_cfg.c
 SRCS_omapl138-evm = edma3_omapl138_cfg.c
 SRCS_c6748-evm = edma3_c6748_cfg.c
 SRCS_da830-evm = edma3_da830_cfg.c
 SRCS_omap4-evm = edma3_omap4_cfg.c
-SRCS_ti814x-evm = edma3_ti814x_cfg.c
-SRCS_tda2xx-evm = edma3_tda2xx_cfg.c
-SRCS_ti816x-evm = edma3_ti816x_cfg.c
+SRCS_ti814x = edma3_ti814x_cfg.c
+ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
+SRCS_COMMON += edma3_tda2xx_cfg.c
+endif
+SRCS_tda3xx = edma3_tda3xx_cfg.c
+SRCS_ti816x = edma3_ti816x_cfg.c
+SRCS_am335x = edma3_am335x_cfg.c
+SRCS_am437x = edma3_am437x_cfg.c
 SRCS_c6a811x-evm = edma3_c6a811x_cfg.c
-SRCS_ti816x-sim = edma3_ti816x_cfg.c
 CFLAGS_LOCAL_generic = -DGENERIC
 
 # Include common make files
-include $(ROOTDIR)/makerules/common.mk
+ifeq ($(MAKERULEDIR), )
+#Makerule path not defined, define this and assume relative path from ROOTDIR
+  MAKERULEDIR := $(ROOTDIR)/makerules
+  export MAKERULEDIR
+endif
+include $(MAKERULEDIR)/common.mk
 
-# OBJs and libraries are built by using rule defined in rules_<target>.mk 
+# OBJs and libraries are built by using rule defined in rules_<target>.mk
 #     and need not be explicitly specified here
 
 # Nothing beyond this point