Changes to compile with devkit
[keystone-rtos/netapi.git] / ti / runtime / netapi / test / build / Makefile
index 387db01cf9e7869be994f3d6245a3e633ed69720..5482c1932c57ee2fe42e05b6d6a5a92b22143b34 100755 (executable)
@@ -94,8 +94,7 @@ clean:
 
 
 $(ARMV7OBJDIR)/netapi/test/%.o: $(NETAPI_INC_DIR)/ti/runtime/netapi/test/%.c $(ARMV7OBJDIR)/netapi/test/.created
-       @echo netapi inc dir = $(NETAPI_INC_DIR)
-       @echo compiling $< ..............
+       @echo compiling $<
        @echo workdir = $(WORKDIR)
        $(CC) -c  $(CFLAGS)  $<  -o $@
 
@@ -110,14 +109,14 @@ $(ARMV7BINDIR)/netapi/test/.created:
 $(ARMV7BINDIR)/netapi/test/net_test_loopback:  $(NT_OBJS) $(TRIE_OBJS)
        $(CC) $(LDFLAGS)  $(NT_OBJS) $(TRIE_OBJS) $(INTERNALLINKDEFS)  -o $(ARMV7BINDIR)/netapi/test/net_test_loopback
 
-$(ARMV7BINDIR)/netapi/test/net_test_max_params:  $(NT_MAX_PARAMS_OBJS) $(TRIE_OBJS) $(ARMV7LIBDIR)/libnetapi.a
+$(ARMV7BINDIR)/netapi/test/net_test_max_params:  $(NT_MAX_PARAMS_OBJS) $(TRIE_OBJS)
        $(CC) $(LDFLAGS)  $(NT_MAX_PARAMS_OBJS) $(TRIE_OBJS) $(INTERNALLINKDEFS)  -o $(ARMV7BINDIR)/netapi/test/net_test_max_params
-$(ARMV7BINDIR)/netapi/test/net_test_router:  $(NT_ROUTER_OBJS) $(TRIE_OBJS) $(ARMV7LIBDIR)/libnetapi.a
+$(ARMV7BINDIR)/netapi/test/net_test_router:  $(NT_ROUTER_OBJS) $(TRIE_OBJS)
        $(CC) $(LDFLAGS)  $(NT_ROUTER_OBJS) $(TRIE_OBJS) $(INTERNALLINKDEFS)  -o $(ARMV7BINDIR)/netapi/test/net_test_router
 
-$(ARMV7BINDIR)/netapi/test/nt_bridge:  $(NTB_OBJS) $(TRIE_OBJS) $(ARMV7LIBDIR)/libnetapi.a
+$(ARMV7BINDIR)/netapi/test/nt_bridge:  $(NTB_OBJS) $(TRIE_OBJS)
        $(CC) $(LDFLAGS)  $(NTB_OBJS) $(TRIE_OBJS) $(INTERNALLINKDEFS)  -o $(ARMV7BINDIR)/netapi/test/nt_bridge
 
-$(ARMV7BINDIR)/netapi/test/ifdma_test:  $(IFDMA_OBJS) $(ARMV7LIBDIR)/libnetapi.a
+$(ARMV7BINDIR)/netapi/test/ifdma_test:  $(IFDMA_OBJS)
        $(CC) $(LDFLAGS)  $(IFDMA_OBJS) $(INTERNALLINKDEFS)  -o $(ARMV7BINDIR)/netapi/test/ifdma_test