allocate canny variables from stack
[processor-sdk/gst-plugin-dsp66.git] / configure.ac
1 dnl required version of autoconf
2 AC_PREREQ([2.53])
4 dnl TODO: fill in your package name and package version here
5 AC_INIT([gst-dsp66],[1.0.0])
7 dnl required versions of gstreamer and plugins-base
8 GST_REQUIRED=1.0.0
9 GSTPB_REQUIRED=1.0.0
11 AC_CONFIG_SRCDIR([src/gstdsp66.c])
12 AC_CONFIG_HEADERS([config.h])
14 dnl required version of automake
15 AM_INIT_AUTOMAKE([1.10])
17 dnl enable mainainer mode by default
18 AM_MAINTAINER_MODE
20 dnl check for tools
21 AC_PROG_CC
23 dnl required version of libtool
24 LT_PREREQ([2.2.6])
25 LT_INIT
26 AM_GNU_GETTEXT_VERSION([0.12.1])
28 dnl give error and exit if we don't have pkgconfig
29 AC_CHECK_PROG(HAVE_PKGCONFIG, pkg-config, [ ], [
30   AC_MSG_ERROR([You need to have pkg-config installed!])
31 ])
34 dnl Check for the required version of GStreamer core (and gst-plugins-base)
35 dnl This will export GST_CFLAGS and GST_LIBS variables for use in Makefile.am
36 dnl
37 dnl If you need libraries from gst-plugins-base here, also add:
38 dnl for libgstaudio-1.0: gstreamer-audio-1.0 >= $GST_REQUIRED
39 dnl for libgstvideo-1.0: gstreamer-video-1.0 >= $GST_REQUIRED
40 dnl for libgsttag-1.0: gstreamer-tag-1.0 >= $GST_REQUIRED
41 dnl for libgstpbutils-1.0: gstreamer-pbutils-1.0 >= $GST_REQUIRED
42 dnl for libgstfft-1.0: gstreamer-fft-1.0 >= $GST_REQUIRED
43 dnl for libgstinterfaces-1.0: gstreamer-interfaces-1.0 >= $GST_REQUIRED
44 dnl for libgstrtp-1.0: gstreamer-rtp-1.0 >= $GST_REQUIRED
45 dnl for libgstrtsp-1.0: gstreamer-rtsp-1.0 >= $GST_REQUIRED
46 dnl etc.
47 PKG_CHECK_MODULES(GST, [
48   gstreamer-1.0 >= $GST_REQUIRED
49   gstreamer-base-1.0 >= $GST_REQUIRED
50   gstreamer-controller-1.0 >= $GST_REQUIRED
51 ], [
52   AC_SUBST(GST_CFLAGS)
53   AC_SUBST(GST_LIBS)
54 ], [
55   AC_MSG_ERROR([
56       You need to install or upgrade the GStreamer development
57       packages on your system. On debian-based systems these are
58       libgstreamer1.0-dev and libgstreamer-plugins-base1.0-dev.
59       on RPM-based systems gstreamer1.0-devel, libgstreamer1.0-devel
60       or similar. The minimum version required is $GST_REQUIRED.
61   ])
62 ])
64 dnl check if compiler understands -Wall (if yes, add -Wall to GST_CFLAGS)
65 AC_MSG_CHECKING([to see if compiler understands -Wall])
66 save_CFLAGS="$CFLAGS"
67 CFLAGS="$CFLAGS -Wall"
68 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([ ], [ ])], [
69   GST_CFLAGS="$GST_CFLAGS -Wall"
70   AC_MSG_RESULT([yes])
71 ], [
72   AC_MSG_RESULT([no])
73 ])
75 dnl set the plugindir where plugins should be installed (for src/Makefile.am)
76 if test "x${prefix}" = "x$HOME"; then
77   plugindir="$HOME/.gstreamer-1.0/plugins"
78 else
79   plugindir="\$(libdir)/gstreamer-1.0"
80 fi
81 AC_SUBST(plugindir)
83 dnl set proper LDFLAGS for plugins
84 GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*gst_plugin_desc\$\$' $GST_ALL_LDFLAGS"
85 AC_SUBST(GST_PLUGIN_LDFLAGS)
87 AC_CONFIG_FILES([Makefile src/Makefile])
88 AC_OUTPUT