apps: machine: zynqmp_r5: correct IPI setting.
[processor-sdk/open-amp.git] / cmake / depends.cmake
1 if (WITH_LIBMETAL_FIND)
2   find_package (Libmetal REQUIRED)
3   collect (PROJECT_INC_DIRS "${LIBMETAL_INCLUDE_DIR}")
4   collect (PROJECT_LIB_DIRS "${LIBMETAL_LIB_DIR}")
5   collect (PROJECT_LIB_DEPS "${LIBMETAL_LIB}")
6 endif (WITH_LIBMETAL_FIND)
8 if ("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
9   check_include_files (stdatomic.h HAVE_STDATOMIC_H)
11 else ("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
12   set (_saved_cmake_required_flags ${CMAKE_REQUIRED_FLAGS})
13   set (CMAKE_REQUIRED_FLAGS "-c")
14   check_include_files (stdatomic.h HAVE_STDATOMIC_H)
15   set (CMAKE_REQUIRED_FLAGS ${_saved_cmake_required_flags})
16 endif ("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
17 # vim: expandtab:ts=2:sw=2:smartindent