]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - processor-sdk/open-amp.git/blobdiff - apps/rpc_demo/CMakeLists.txt
Apps: CMake: allow system machine linker option
[processor-sdk/open-amp.git] / apps / rpc_demo / CMakeLists.txt
index 1103a173fbf31936a36b0dcfb1cf8e8bf3d8ab58..d73188960075c6b0c098b426b4d0f0cabeaff5d4 100644 (file)
@@ -9,7 +9,7 @@ collector_list (_list PROJECT_LIB_DIRS)
 collector_list (_app_list APP_LIB_DIRS)
 link_directories (${_list} ${_app_list})
 
-get_property (_linker_script GLOBAL PROPERTY APP_LINKER_SCRIPT)
+get_property (_linker_opt GLOBAL PROPERTY APP_LINKER_OPT)
 collector_list (_deps PROJECT_LIB_DEPS)
 
 set (OPENAMP_LIB open_amp)
@@ -39,7 +39,7 @@ foreach (_app ${app_list})
       add_executable (${_app}.out ${_sources})
       set_source_files_properties(${_sources} PROPERTIES COMPILE_FLAGS "${_cflags}")
 
-      target_link_libraries(${_app}.out -Wl,-Map=${_app}.map -Wl,--gc-sections -T\"${_linker_script}\" -Wl,--start-group ${OPENAMP_LIB}-static ${_deps} -Wl,--end-group)
+      target_link_libraries(${_app}.out -Wl,-Map=${_app}.map -Wl,--gc-sections ${_linker_opt} -Wl,--start-group ${OPENAMP_LIB}-static ${_deps} -Wl,--end-group)
       install (TARGETS ${_app}.out RUNTIME DESTINATION bin)
     endif (${PROJECT_SYSTEM} STREQUAL "linux" )
   endif (WITH_STATIC_LIB)