]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - processor-sdk/pdk.git/blobdiff - packages/ti/diag/examples/esm_example_app/makefile
PDK-5910: Additional cleanup in ESM example app.
[processor-sdk/pdk.git] / packages / ti / diag / examples / esm_example_app / makefile
index ea7adf58075389d225446d35bbffb9e463270e5f..84a87896d075391f57ddedd80257be1f56cc1f12 100644 (file)
@@ -7,7 +7,6 @@ include $(PDK_INSTALL_PATH)/ti/build/Rules.make
 
 APP_NAME = diag_ex_esm_example_app
 
-$(info DSJ - GOT HERE)
 BUILD_OS_TYPE=baremetal
 
 SRCDIR = . ../common
@@ -20,19 +19,23 @@ INCDIR += $(SOC)/. ../common
 INCLUDE_EXTERNAL_INTERFACES = pdk sdr
 
 # List all the components required by the application
+COMP_LIST_COMMON = csl_utils_common csl_uart_console
+COMP_LIST_COMMON += sdr
+
+ifeq ($(SOC),$(filter $(SOC), j721e am64x))
+  COMP_LIST_COMMON += $(PDK_COMMON_BAREMETAL_COMP)
+endif
+
 ifeq ($(CSL_BUILD),$(filter $(CSL_BUILD), CSL))
-  COMP_LIST_COMMON = csl
+  ifneq ($(SOC),$(filter $(SOC), j721e am64x))
+    COMP_LIST_COMMON = csl
+  endif
 else
   COMP_LIST_COMMON = csl2 csl_trim
 endif
 
-COMP_LIST_COMMON += csl_utils_common csl_uart_console
-ifeq ($(SOC),$(filter $(SOC), j721e am64x))
-  COMP_LIST_COMMON += csl_init osal_nonos board uart sciclient i2c
-endif
-COMP_LIST_COMMON += sdr
 # Common source files and CFLAGS across all platforms and cores
-PACKAGE_SRCS_COMMON = .
+PACKAGE_SRCS_COMMON = . ../common ../diag_ex_component.mk
 
 ifeq ($(SOC),$(filter $(SOC), j721e am64x))
   SRCS_COMMON = main.c esm.c event_trig.c diag_utils.c