]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - processor-sdk/pdk.git/blobdiff - packages/ti/drv/uart/uart_component.mk
[PDK-9493] UART: Support FreeRTOS on R5 cores
[processor-sdk/pdk.git] / packages / ti / drv / uart / uart_component.mk
old mode 100755 (executable)
new mode 100644 (file)
index 1b4db5c..9004156
 ifeq ($(uart_component_make_include), )
 
 # under other list
-drvuart_BOARDLIST       = am65xx_evm am65xx_idk j721e_sim j721e_evm j7200_evm am64x_evm
+drvuart_BOARDLIST       = am65xx_evm am65xx_idk j721e_sim j721e_evm j7200_evm am64x_evm tpr12_evm tpr12_qt awr294x_evm
+drvuart_freertos_BOARDLIST = am65xx_evm j721e_evm j7200_evm tpr12_evm
 drvuart_dma_SOCLIST     = tda2xx tda2px dra72x dra75x tda2ex tda3xx dra78x am574x am572x am571x k2h k2k k2l k2e k2g c6678 c6657 omapl137 omapl138 am437x am65xx j721e j7200
-drvuart_SOCLIST         = tda2xx tda2px dra72x dra75x tda2ex tda3xx dra78x am574x am572x am571x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx j721e j7200 am64x
+drvuart_SOCLIST         = tda2xx tda2px dra72x dra75x tda2ex tda3xx dra78x am574x am572x am571x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx j721e j7200 am64x tpr12 awr294x
 drvuart_tda2xx_CORELIST = ipu1_0
 drvuart_tda2px_CORELIST = ipu1_0
 drvuart_tda2ex_CORELIST = ipu1_0
@@ -92,11 +93,18 @@ drvuart_c6657_CORELIST  = c66x
 drvuart_am437x_CORELIST = a9host
 drvuart_am335x_CORELIST = a8host pru_0 pru_1
 drvuart_am65xx_CORELIST = mpu1_0 mcu1_0 mcu1_1
+drvuart_am65xx_FREERTOS_CORELIST = mcu1_0 mcu1_1
 drvuart_j721e_CORELIST = $(DEFAULT_j721e_CORELIST)
 drvuart_j721e_CORELISTARM = mpu1_0 mcu1_0 mcu1_1 mcu2_0 mcu2_1 mcu3_0 mcu3_1
+drvuart_j721e_FREERTOS_CORELIST = mcu1_0 mcu1_1 mcu2_0 mcu2_1 mcu3_0 mcu3_1
 drvuart_j7200_CORELIST = $(DEFAULT_j7200_CORELIST)
 drvuart_j7200_CORELISTARM = mpu1_0 mcu1_0 mcu1_1 mcu2_0 mcu2_1
+drvuart_j7200_FREERTOS_CORELIST = mcu1_0 mcu1_1 mcu2_0 mcu2_1
 drvuart_am64x_CORELIST = $(DEFAULT_am64x_CORELIST)
+drvuart_am64x_CORELISTARM = mpu1_0 mcu1_0 mcu1_1 mcu2_0 mcu2_1
+drvuart_tpr12_CORELIST = mcu1_0 c66xdsp_1
+drvuart_tpr12_FREERTOS_CORELIST = mcu1_0 c66xdsp_1
+drvuart_awr294x_CORELIST = mcu1_0 c66xdsp_1
 
 ############################
 # uart package
@@ -121,11 +129,8 @@ drvuart_FIRM_LIST = $(uart_FIRM_LIST)
 # List below all examples for allowed values
 ############################
 #uart_EXAMPLE_LIST = drv_uart_unit_test drv_uart_polling_mode_app drv_uart_intr_mode_app
-ifeq ($(SOC),$(filter $(SOC), am64x))
-uart_EXAMPLE_LIST = UART_Baremetal_TestApp UART_TestApp
-else
 uart_EXAMPLE_LIST = UART_Baremetal_TestApp UART_Baremetal_DMA_TestApp UART_TestApp UART_SMP_TestApp UART_DMA_TestApp UART_DMA_SMP_TestApp
-endif
+uart_EXAMPLE_LIST += UART_Freertos_TestApp UART_Freertos_DMA_TestApp
 drvuart_EXAMPLE_LIST = $(uart_EXAMPLE_LIST)
 
 #
@@ -153,7 +158,7 @@ export uart_CORE_DEPENDENCY
 export uart_SOC_DEPENDENCY
 uart_PKG_LIST = uart
 uart_INCLUDE = $(uart_PATH)
-uart_SOCLIST = tda2xx tda2px tda2ex tda3xx dra78x am574x am572x am571x dra72x dra75x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx j721e j7200 am64x
+uart_SOCLIST = tda2xx tda2px tda2ex tda3xx dra78x am574x am572x am571x dra72x dra75x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx j721e j7200 am64x tpr12 awr294x
 export uart_SOCLIST
 uart_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
 ifeq ($(SOC),$(filter $(SOC), j721e))
@@ -182,7 +187,7 @@ export uart_indp_CORE_DEPENDENCY
 export uart_indp_SOC_DEPENDENCY
 uart_indp_PKG_LIST = uart_indp
 uart_indp_INCLUDE = $(uart_indp_PATH)
-uart_indp_SOCLIST = tda2xx tda2px tda2ex tda3xx dra78x am574x am572x am571x dra72x dra75x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx am64x
+uart_indp_SOCLIST = tda2xx tda2px tda2ex tda3xx dra78x am574x am572x am571x dra72x dra75x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138
 export uart_indp_SOCLIST
 uart_indp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
 export uart_indp_$(SOC)_CORELIST
@@ -208,7 +213,7 @@ export uart_dma_CORE_DEPENDENCY
 export uart_dma_SOC_DEPENDENCY
 uart_dma_PKG_LIST = uart_dma
 uart_dma_INCLUDE = $(uart_dma_PATH)
-uart_dma_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 omapl137 omapl138 am437x am65xx j721e j7200 am335x
+uart_dma_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 omapl137 omapl138 am437x am65xx j721e j7200 am335x am64x tpr12 awr294x
 export uart_dma_SOCLIST
 uart_dma_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
 export uart_dma_$(SOC)_CORELIST
@@ -234,7 +239,7 @@ export uart_profile_CORE_DEPENDENCY
 export uart_profile_SOC_DEPENDENCY
 uart_profile_PKG_LIST = uart_profile
 uart_profile_INCLUDE = $(uart_profile_PATH)
-uart_profile_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx am64x
+uart_profile_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138
 export uart_profile_SOCLIST
 uart_profile_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
 export uart_profile_$(SOC)_CORELIST
@@ -260,7 +265,7 @@ export uart_profile_indp_CORE_DEPENDENCY
 export uart_profile_indp_SOC_DEPENDENCY
 uart_profile_indp_PKG_LIST = uart_profile_indp
 uart_profile_indp_INCLUDE = $(uart_profile_indp_PATH)
-uart_profile_indp_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx am64x
+uart_profile_indp_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138
 export uart_profile_indp_SOCLIST
 uart_profile_indp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
 export uart_profile_indp_$(SOC)_CORELIST
@@ -286,7 +291,7 @@ export uart_dma_profile_CORE_DEPENDENCY
 export uart_dma_profile_SOC_DEPENDENCY
 uart_dma_profile_PKG_LIST = uart_dma_profile
 uart_dma_profile_INCLUDE = $(uart_dma_profile_PATH)
-uart_dma_profile_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 am437x am65xx am335x
+uart_dma_profile_SOCLIST = am574x am572x am571x dra72x dra75x dra78x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x
 export uart_dma_profile_SOCLIST
 uart_dma_profile_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
 export uart_dma_profile_$(SOC)_CORELIST
@@ -312,7 +317,7 @@ export uart_console_CORE_DEPENDENCY
 export uart_console_SOC_DEPENDENCY
 uart_console_PKG_LIST = uart_console
 uart_console_INCLUDE = $(uart_console_PATH)
-uart_console_SOCLIST = tda2xx tda2px tda2ex tda3xx am65xx j721e j7200
+uart_console_SOCLIST = tda2xx tda2px tda2ex tda3xx am65xx j721e j7200 tpr12 awr294x
 export uart_console_SOCLIST
 uart_console_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
 export uart_console_$(SOC)_CORELIST
@@ -368,7 +373,7 @@ UART_Baremetal_TestApp_PKG_LIST = UART_Baremetal_TestApp
 UART_Baremetal_TestApp_INCLUDE = $(UART_Baremetal_TestApp_PATH)
 UART_Baremetal_TestApp_BOARDLIST = $(drvuart_BOARDLIST)
 export UART_Baremetal_TestApp_BOARDLIST
-ifeq ($(SOC),$(filter $(SOC), j721e j7200))
+ifeq ($(SOC),$(filter $(SOC), j721e j7200 am64x))
 UART_Baremetal_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELISTARM)
 else
 UART_Baremetal_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
@@ -398,7 +403,7 @@ UART_Baremetal_DMA_TestApp_PKG_LIST = UART_Baremetal_DMA_TestApp
 UART_Baremetal_DMA_TestApp_INCLUDE = $(UART_Baremetal_DMA_TestApp_PATH)
 UART_Baremetal_DMA_TestApp_BOARDLIST = $(drvuart_BOARDLIST)
 export UART_Baremetal_DMA_TestApp_BOARDLIST
-ifeq ($(SOC),$(filter $(SOC), j721e j7200))
+ifeq ($(SOC),$(filter $(SOC), j721e j7200 am64x))
 UART_Baremetal_DMA_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELISTARM)
 else
 UART_Baremetal_DMA_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
@@ -409,6 +414,32 @@ UART_Baremetal_DMA_TestApp_SBL_APPIMAGEGEN = yes
 export UART_Baremetal_DMA_TestApp_SBL_APPIMAGEGEN
 endif
 
+# UART unit test freertos app
+export UART_Freertos_TestApp_COMP_LIST = UART_Freertos_TestApp
+UART_Freertos_TestApp_RELPATH = ti/drv/uart/test
+UART_Freertos_TestApp_PATH = $(PDK_UART_COMP_PATH)/test
+export UART_Freertos_TestApp_BOARD_DEPENDENCY = yes
+export UART_Freertos_TestApp_CORE_DEPENDENCY = no
+export UART_Freertos_TestApp_MAKEFILE = -f makefile IS_FREERTOS=yes
+UART_Freertos_TestApp_PKG_LIST = UART_Freertos_TestApp
+UART_Freertos_TestApp_INCLUDE = $(UART_Freertos_TestApp_PATH)
+export UART_Freertos_TestApp_BOARDLIST = $(drvuart_freertos_BOARDLIST)
+export UART_Freertos_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_FREERTOS_CORELIST)
+export UART_Freertos_TestApp_SBL_APPIMAGEGEN = yes
+
+# UART unit test freertos dma app
+export UART_Freertos_DMA_TestApp_COMP_LIST = UART_Freertos_DMA_TestApp
+UART_Freertos_DMA_TestApp_RELPATH = ti/drv/uart/test
+UART_Freertos_DMA_TestApp_PATH = $(PDK_UART_COMP_PATH)/test
+export UART_Freertos_DMA_TestApp_BOARD_DEPENDENCY = yes
+export UART_Freertos_DMA_TestApp_CORE_DEPENDENCY = no
+export UART_Freertos_DMA_TestApp_MAKEFILE = -f makefile IS_FREERTOS=yes DMA=enable
+UART_Freertos_DMA_TestApp_PKG_LIST = UART_Freertos_DMA_TestApp
+UART_Freertos_DMA_TestApp_INCLUDE = $(UART_Freertos_DMA_TestApp_PATH)
+export UART_Freertos_DMA_TestApp_BOARDLIST = tpr12_evm
+export UART_Freertos_DMA_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
+export UART_Freertos_DMA_TestApp_SBL_APPIMAGEGEN = yes
+
 # UART unit test rtos app
 UART_TestApp_COMP_LIST = UART_TestApp
 UART_TestApp_RELPATH = ti/drv/uart/test
@@ -478,7 +509,11 @@ UART_DMA_TestApp_PKG_LIST = UART_DMA_TestApp
 UART_DMA_TestApp_INCLUDE = $(UART_DMA_TestApp_PATH)
 UART_DMA_TestApp_BOARDLIST = $(drvuart_BOARDLIST)
 export UART_DMA_TestApp_BOARDLIST
+ifeq ($(SOC),$(filter $(SOC), j721e j7200 am64x))
+UART_DMA_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELISTARM)
+else
 UART_DMA_TestApp_$(SOC)_CORELIST = $(drvuart_$(SOC)_CORELIST)
+endif
 export UART_DMA_TestApp_$(SOC)_CORELIST
 ifeq ($(SOC),$(filter $(SOC), am65xx j721e j7200 am64x))
 UART_DMA_TestApp_SBL_APPIMAGEGEN = yes