]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - processor-sdk/pdk.git/blobdiff - packages/ti/osal/osal_component.mk
[PDK-9369] OSAL: FreeRTOS Support for J721E/J7VCL/AM65xx R5F cores
[processor-sdk/pdk.git] / packages / ti / osal / osal_component.mk
index ac627923be66bc9169a9016d18707831adc498c3..99a84d60bb554bac9969249ea413031482572334 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (c) 2016-2018, Texas Instruments Incorporated
+# Copyright (c) 2016-2021, Texas Instruments Incorporated
 # All rights reserved.
 #
 # Redistribution and use in source and binary forms, with or without
 #
 ifeq ($(osal_component_make_include), )
 
-libosal_BOARDLIST       = evmAM572x evmAM335x evmAM437x iceK2G idkAM574x idkAM572x idkAM571x idkAM437x am65xx_evm am65xx_idk evmOMAPL137 lcdkOMAPL138 evmK2E evmK2H evmK2K evmK2L j721e_evm j7200_evm
-libosal_SOCLIST         = tda2xx tda2px tda2ex tda3xx dra78x dra72x dra75x am574x am572x am571x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx j721e j7200 am64x 
+libosal_BOARDLIST       = evmAM572x evmAM335x evmAM437x iceK2G idkAM574x idkAM572x idkAM571x idkAM437x am65xx_evm am65xx_idk evmOMAPL137 lcdkOMAPL138 evmK2E evmK2H evmK2K evmK2L j721e_evm j7200_evm am64x_evm tpr12_evm tpr12_qt awr294x_evm
+libosal_SOCLIST         = tda2xx tda2px tda2ex tda3xx dra78x dra72x dra75x am574x am572x am571x k2h k2k k2l k2e k2g c6678 c6657 am437x am335x omapl137 omapl138 am65xx j721e j7200 am64x tpr12 awr294x
+libosal_freertos_BOARDLIST  = am65xx_evm j721e_evm j7200_evm tpr12_evm awr294x_evm
+libosal_freertos_SOCLIST    = am65xx j721e j7200 tpr12 awr294x
 libosal_tda2xx_CORELIST = a15_0 ipu1_0
 libosal_tda2px_CORELIST = a15_0 ipu1_0
 libosal_tda2ex_CORELIST = a15_0 ipu1_0
@@ -89,10 +91,18 @@ libosal_c6678_CORELIST  = c66x
 libosal_c6657_CORELIST  = c66x
 libosal_am437x_CORELIST = a9host
 libosal_am335x_CORELIST = a8host
-libosal_am65xx_CORELIST = mpu1_0 mcu1_0
+libosal_am65xx_CORELIST = $(DEFAULT_am65xx_CORELIST)
 libosal_j721e_CORELIST = $(DEFAULT_j721e_CORELIST)
 libosal_j7200_CORELIST = $(DEFAULT_j7200_CORELIST)
 libosal_am64x_CORELIST = $(DEFAULT_am64x_CORELIST)
+libosal_tpr12_CORELIST = $(DEFAULT_tpr12_CORELIST)
+libosal_awr294x_CORELIST = $(DEFAULT_awr294x_CORELIST)
+libosal_freertos_am65xx_CORELIST = mcu1_0 mcu1_1
+libosal_freertos_j721e_CORELIST = mcu1_0 mcu1_1 mcu2_0 mcu2_1 mcu3_0 mcu3_1
+libosal_freertos_j7200_CORELIST = mcu1_0 mcu1_1 mcu2_0 mcu2_1
+libosal_freertos_tpr12_CORELIST = $(DEFAULT_tpr12_CORELIST)
+libosal_freertos_awr294x_CORELIST = $(DEFAULT_awr294x_CORELIST)
+
 
 ############################
 # osal package
@@ -103,6 +113,7 @@ osal_LIB_LIST = osal_nonos osal_nonos_indp
 ifeq ($(BUILD_OS_TYPE),tirtos)
 osal_LIB_LIST += osal_tirtos osal_tirtos_indp
 endif
+osal_LIB_LIST += osal_freertos
 libosal_LIB_LIST = $(osal_LIB_LIST)
 
 ############################
@@ -142,6 +153,9 @@ osal_nonos_INCLUDE = $(osal_nonos_PATH)
 osal_nonos_SOCLIST = $(libosal_SOCLIST)
 export osal_nonos_SOCLIST
 osal_nonos_$(SOC)_CORELIST = $(libosal_$(SOC)_CORELIST)
+ifeq ($(SOC),$(filter $(SOC), j721e))
+osal_nonos_$(SOC)_CORELIST += c7x-hostemu
+endif
 export osal_nonos_$(SOC)_CORELIST
 
 # OSAL NONOS LIB DEVICE INDEPENDENT
@@ -166,7 +180,7 @@ export osal_nonos_indp_SOC_DEPENDENCY
 osal_nonos_indp_PKG_LIST = osal_nonos_indp
 export osal_nonos_indp_PKG_LIST
 osal_nonos_indp_INCLUDE = $(osal_nonos_indp_PATH)
-osal_nonos_indp_SOCLIST = $(libosal_SOCLIST)
+osal_nonos_indp_SOCLIST = 
 export osal_nonos_indp_SOCLIST
 osal_nonos_indp_$(SOC)_CORELIST = $(libosal_$(SOC)_CORELIST)
 export osal_nonos_indp_$(SOC)_CORELIST
@@ -220,11 +234,38 @@ export osal_tirtos_indp_SOC_DEPENDENCY
 osal_tirtos_indp_PKG_LIST = osal_tirtos_indp
 export osal_tirtos_indp_PKG_LIST
 osal_tirtos_indp_INCLUDE = $(osal_tirtos_indp_PATH)
-osal_tirtos_indp_SOCLIST = $(libosal_SOCLIST)
+osal_tirtos_indp_SOCLIST = 
 export osal_tirtos_indp_SOCLIST
 osal_tirtos_indp_$(SOC)_CORELIST = $(libosal_$(SOC)_CORELIST)
 export osal_tirtos_indp_$(SOC)_CORELIST
 
+# OSAL FREE RTOS LIB
+osal_freertos_COMP_LIST = osal_freertos
+osal_freertos_RELPATH = ti/osal
+osal_freertos_PATH = $(PDK_OSAL_COMP_PATH)
+osal_freertos_LIBNAME = ti.osal
+export osal_freertos_LIBNAME
+osal_freertos_LIBPATH = $(osal_freertos_PATH)/lib/freertos
+export osal_freertos_LIBPATH
+osal_freertos_OBJPATH = $(osal_freertos_RELPATH)/osal_freertos
+export osal_freertos_OBJPATH
+osal_freertos_MAKEFILE = -f build/makefile_freertos.mk
+export osal_freertos_MAKEFILE
+osal_freertos_PLATFORM_DEPENDENCY = no
+osal_freertos_CORE_DEPENDENCY = no
+osal_freertos_SOC_DEPENDENCY = yes
+export osal_freertos_COMP_LIST
+export osal_freertos_PLATFORM_DEPENDENCY
+export osal_freertos_CORE_DEPENDENCY
+export osal_freertos_SOC_DEPENDENCY
+osal_freertos_PKG_LIST = osal_freertos
+export osal_freertos_PKG_LIST
+osal_freertos_INCLUDE = $(osal_freertos_PATH)
+osal_freertos_SOCLIST = $(libosal_freertos_SOCLIST)
+export osal_freertos_SOCLIST
+osal_freertos_$(SOC)_CORELIST = $(libosal_freertos_$(SOC)_CORELIST)
+export osal_freertos_$(SOC)_CORELIST
+
 #
 # OSAL Examples
 #
@@ -240,10 +281,28 @@ OSAL_Baremetal_TestApp_PKG_LIST = OSAL_Baremetal_TestApp
 OSAL_Baremetal_TestApp_INCLUDE = $(OSAL_Baremetal_TestApp_PATH)
 OSAL_Baremetal_TestApp_BOARDLIST = $(libosal_BOARDLIST)
 export OSAL_Baremetal_TestApp_BOARDLIST
-ifeq ($(SOC),$(filter $(SOC), am65xx j721e j7200))
+ifeq ($(SOC),$(filter $(SOC), am65xx j721e j7200 am64x))
 OSAL_Baremetal_TestApp_SBL_APPIMAGEGEN = yes
-export OSAL_Baremetal_TestApp_SBL_APPIMAGEGEN
+else
+OSAL_Baremetal_TestApp_SBL_APPIMAGEGEN = no
 endif
+export OSAL_Baremetal_TestApp_SBL_APPIMAGEGEN
+
+# OSAL FreeRTOS unit test app
+OSAL_freertos_TestApp_COMP_LIST = OSAL_freertos_TestApp
+OSAL_freertos_TestApp_RELPATH = ti/osal/test/freertos
+OSAL_freertos_TestApp_PATH = $(PDK_OSAL_COMP_PATH)/test/freertos
+OSAL_freertos_TestApp_BOARD_DEPENDENCY = yes
+OSAL_freertos_TestApp_CORE_DEPENDENCY = no
+export OSAL_freertos_TestApp_COMP_LIST
+export OSAL_freertos_TestApp_BOARD_DEPENDENCY
+export OSAL_freertos_TestApp_CORE_DEPENDENCY
+OSAL_freertos_TestApp_PKG_LIST = OSAL_freertos_TestApp
+OSAL_freertos_TestApp_INCLUDE = $(OSAL_freertos_TestApp_PATH)
+OSAL_freertos_TestApp_BOARDLIST = $(libosal_freertos_BOARDLIST)
+export OSAL_freertos_TestApp_BOARDLIST
+OSAL_freertos_TestApp_SBL_APPIMAGEGEN = yes
+export OSAL_freertos_TestApp_SBL_APPIMAGEGEN
 
 # OSAL sysbios unit test app
 OSAL_TestApp_COMP_LIST = OSAL_TestApp
@@ -262,10 +321,12 @@ OSAL_TestApp_BOARDLIST = $(libosal_BOARDLIST)
 export OSAL_TestApp_BOARDLIST
 OSAL_TestApp_$(SOC)_CORELIST = $(osal_$(SOC)_CORELIST)
 export OSAL_TestApp_$(SOC)_CORELIST
-ifeq ($(SOC),$(filter $(SOC), am65xx j721e j7200))
+ifeq ($(SOC),$(filter $(SOC), am65xx j721e j7200 am64x tpr12))
 OSAL_TestApp_SBL_APPIMAGEGEN = yes
-export OSAL_TestApp_SBL_APPIMAGEGEN
+else
+OSAL_TestApp_SBL_APPIMAGEGEN = no
 endif
+export OSAL_TestApp_SBL_APPIMAGEGEN
 
 #Default Core List
 OSAL_Baremetal_TestApp_$(SOC)_CORELIST = a15_0 c66x
@@ -332,28 +393,49 @@ ifeq ($(SOC),$(filter $(SOC), dra78x))
 OSAL_Baremetal_TestApp_$(SOC)_CORELIST = ipu1_0 c66x
 endif
 
+ifeq ($(SOC),$(filter $(SOC), am64x))
+ OSAL_TestApp_$(SOC)_CORELIST = mcu1_0 mpu1_0 mcu2_0
+ OSAL_Baremetal_TestApp_$(SOC)_CORELIST = mcu1_0 mpu1_0 m4f_0 mcu2_0
+endif
 
 ifeq ($(SOC),$(filter $(SOC), am65xx))
  OSAL_TestApp_$(SOC)_CORELIST = mpu1_0 mcu1_0
  OSAL_Baremetal_TestApp_$(SOC)_CORELIST = mpu1_0 mcu1_0
+ OSAL_freertos_TestApp_$(SOC)_CORELIST = mcu1_0 mcu1_1
 endif
 
 ifeq ($(SOC),$(filter $(SOC), j721e))
      OSAL_TestApp_$(SOC)_CORELIST = mpu1_0 mcu1_0 mcu2_0 mcu3_0 c66xdsp_1 c7x_1
+ OSAL_TestApp_$(SOC)_CORELIST = mpu1_0 mcu1_0 mcu2_0 mcu3_0 c66xdsp_1 c7x_1
  OSAL_Baremetal_TestApp_$(SOC)_CORELIST = mpu1_0 mcu1_0 mcu2_0 mcu3_0
+ OSAL_freertos_TestApp_$(SOC)_CORELIST = mcu1_0 mcu1_1 mcu2_0 mcu2_1 mcu3_0 mcu3_1
 endif
 
 ifeq ($(SOC),$(filter $(SOC), j7200))
  OSAL_TestApp_$(SOC)_CORELIST = mpu1_0 mcu1_0 mcu2_0
  OSAL_Baremetal_TestApp_$(SOC)_CORELIST = mpu1_0 mcu1_0 mcu2_0
+ OSAL_freertos_TestApp_$(SOC)_CORELIST = mcu1_0 mcu1_1 mcu2_0 mcu2_1
+endif
+
+ifeq ($(SOC),$(filter $(SOC), tpr12))
+ OSAL_TestApp_$(SOC)_CORELIST = mcu1_0 c66xdsp_1
+ OSAL_Baremetal_TestApp_$(SOC)_CORELIST = mcu1_0 c66xdsp_1
+ OSAL_freertos_TestApp_$(SOC)_CORELIST = mcu1_0 c66xdsp_1
+endif
+
+ifeq ($(SOC),$(filter $(SOC), awr294x))
+ OSAL_TestApp_$(SOC)_CORELIST = mcu1_0 c66xdsp_1
+ OSAL_Baremetal_TestApp_$(SOC)_CORELIST = mcu1_0 c66xdsp_1
 endif
 
 export OSAL_Baremetal_TestApp_$(SOC)_CORELIST
 export OSAL_TestApp_$(SOC)_CORELIST
+export OSAL_freertos_TestApp_$(SOC)_CORELIST
 
 osal_EXAMPLE_LIST += OSAL_Baremetal_TestApp
-osal_EXAMPLE_LIST += OSAL_TestApp
+osal_EXAMPLE_LIST += OSAL_freertos_TestApp
 
+# do not support RTOS example for AM64x yet
+osal_EXAMPLE_LIST += OSAL_TestApp
 
 ifeq ($(CPLUSPLUS_BUILD), yes)
 #cpptest