]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - processor-sdk/pdk.git/blobdiff - packages/ti/osal/src/src_common_freertos.mk
[PDK-9782] OSAL: LoadP: Added Load module implementation for FreeRTOS
[processor-sdk/pdk.git] / packages / ti / osal / src / src_common_freertos.mk
index bc7b9577958cd9750510663f779ffa7450b58e70..a5dfe204ffdf2ac7143b31bc5dfeb5ca77c57219 100644 (file)
@@ -5,7 +5,7 @@ INCDIR = . src/freertos src/nonos arch/core
 SRCS_COMMON += HwiP_nonos.c SwiP_nonos.c DebugP_nonos.c RegisterIntr_nonos.c Core_utils.c
 SRCS_COMMON += SemaphoreP_freertos.c TaskP_freertos.c MemoryP_freertos.c Utils_freertos.c
 SRCS_COMMON += ClockP_freertos.c MailboxP_freertos.c MutexP_freertos.c QueueP_freertos.c
-SRCS_COMMON += HeapP_freertos.c HeapP_freertos_internal.c EventP_freertos.c
+SRCS_COMMON += HeapP_freertos.c HeapP_freertos_internal.c EventP_freertos.c LoadP_freertos.c
 
 PACKAGE_SRCS_COMMON = makefile HwiP.h SwiP.h MuxIntcP.h osal.h osal_component.mk SemaphoreP.h \
                       TimerP.h RegisterIntr.h EventCombinerP.h CycleprofilerP.h CacheP.h DebugP.h MailboxP.h MutexP.h ClockP.h QueueP.h soc/osal_soc.h soc/$(SOC) \
@@ -13,6 +13,7 @@ PACKAGE_SRCS_COMMON = makefile HwiP.h SwiP.h MuxIntcP.h osal.h osal_component.mk
                       src/nonos/RegisterIntr_nonos.c src/freertos/SemaphoreP_freertos.c src/freertos/TaskP_freertos.c src/freertos/Utils_freertos.c src/nonos/DebugP_nonos.c \
                       src/freertos/MemoryP_freertos.c src/freertos/ClockP_freertos.c src/freertos/MailboxP_freertos.c src/freertos/MutexP_freertos.c src/freertos/QueueP_freertos.c \
                       HeapP.h src/freertos/HeapP_freertos.c src/freertos/HeapP_freertos_internal.c src/freertos/HeapP_freertos_internal.h EventP.h src/freertos/EventP_freertos.c \
+                      LoadP.h src/freertos/LoadP_freertos.c \
                       src/src_common_freertos.mk src/Module.xs \
                       arch/core/Core_utils.c docs/OSAL_SoftwareManifest.html docs/ReleaseNotes_OSAL.pdf \
                       build \