]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - processor-sdk/performance-audio-sr.git/blobdiff - psdk_cust/pdk_k2g_1_0_1_2_eng/packages/ti/csl/csl_component.mk
Removed IPC and PDK from psdk_cust folder.
[processor-sdk/performance-audio-sr.git] / psdk_cust / pdk_k2g_1_0_1_2_eng / packages / ti / csl / csl_component.mk
diff --git a/psdk_cust/pdk_k2g_1_0_1_2_eng/packages/ti/csl/csl_component.mk b/psdk_cust/pdk_k2g_1_0_1_2_eng/packages/ti/csl/csl_component.mk
deleted file mode 100644 (file)
index 5f07d78..0000000
+++ /dev/null
@@ -1,545 +0,0 @@
-#*******************************************************************************
-#                                                                              *
-# Copyright (c) 2015 Texas Instruments Incorporated - http://www.ti.com/       *
-#                                                                              *
-#*******************************************************************************
-
-# File: csl_component.mk
-#       This file is component include make file of CSL library.
-# List of variables set in this file and their purpose:
-# <mod>_RELPATH        - This is the relative path of the module, typically from
-#                        top-level directory of the package
-# <mod>_PATH           - This is the absolute path of the module. It derives from
-#                        absolute path of the top-level directory (set in env.mk)
-#                        and relative path set above
-# <mod>_INCLUDE        - This is the path that has interface header files of the
-#                        module. This can be multiple directories (space separated)
-# <mod>_PKG_LIST       - Names of the modules (and sub-modules) that are a part
-#                        part of this module, including itself.
-# <mod>_PLATFORM_DEPENDENCY - "yes": means the code for this module depends on
-#                             platform and the compiled obj/lib has to be kept
-#                             under <platform> directory
-#                             "no" or "" or if this variable is not defined: means
-#                             this module has no platform dependent code and hence
-#                             the obj/libs are not kept under <platform> dir.
-# <mod>_CORE_DEPENDENCY     - "yes": means the code for this module depends on
-#                             core and the compiled obj/lib has to be kept
-#                             under <core> directory
-#                             "no" or "" or if this variable is not defined: means
-#                             this module has no core dependent code and hence
-#                             the obj/libs are not kept under <core> dir.
-# <mod>_APP_STAGE_FILES     - List of source files that belongs to the module
-#                             <mod>, but that needs to be compiled at application
-#                             build stage (in the context of the app). This is
-#                             primarily for link time configurations or if the
-#                             source file is dependent on options/defines that are
-#                             application dependent. This can be left blank or
-#                             not defined at all, in which case, it means there
-#                             no source files in the module <mod> that are required
-#                             to be compiled in the application build stage.
-#
-ifeq ($(csl_component_make_include), )
-
-############################
-# csl package
-# List of components included under csl
-# The components included here are built and will be part of csl
-############################
-csl_LIB_LIST = csl csl_utils_common
-
-############################
-# csl example
-# List of example under csl
-# All the tests mentioned in list are built when test target is called
-# List below all example for allowed values - note the list is populated in each example
-############################
-csl_EXAMPLE_LIST =
-
-#
-# CSL Modules
-#
-
-# CSL
-csl_COMP_LIST = csl
-csl_RELPATH = ti/csl
-csl_PATH = $(pdk_PATH)/$(csl_RELPATH)
-csl_LIBNAME = ti.csl
-csl_LIBPATH = $(csl_PATH)
-export csl_LIBNAME
-export csl_LIBPATH
-csl_PLATFORM_DEPENDENCY = yes
-csl_CORE_DEPENDENCY = no
-export csl_COMP_LIST
-export csl_PLATFORM_DEPENDENCY
-export csl_CORE_DEPENDENCY
-csl_PKG_LIST = csl
-export csl_PKG_LIST
-csl_INCLUDE = $(pdk_PATH)/$(csl_RELPATH)
-csl_SOCLIST = tda2xx am572x dra7xx tda2ex am571x tda3xx
-export csl_SOCLIST
-csl_$(SOC)_CORELIST = $(DEFAULT_$(SOC)_CORELIST)
-export csl_$(SOC)_CORELIST
-
-# Utils Common
-csl_utils_common_COMP_LIST = csl_utils_common
-csl_utils_common_RELPATH = ti/csl/example/utils/common
-csl_utils_common_PATH = $(pdk_PATH)/$(csl_utils_common_RELPATH)
-csl_utils_common_LIBNAME = csl_utils_common
-csl_utils_common_LIBPATH = $(csl_utils_common_PATH)
-export csl_utils_common_LIBNAME
-export csl_utils_common_LIBPATH
-csl_utils_common_PLATFORM_DEPENDENCY = yes
-csl_utils_common_CORE_DEPENDENCY = no
-export csl_utils_common_COMP_LIST
-export csl_utils_common_PLATFORM_DEPENDENCY
-export csl_utils_common_CORE_DEPENDENCY
-csl_utils_common_PKG_LIST = csl_utils_common
-csl_utils_common_INCLUDE = $(pdk_PATH)/$(csl_utils_common_RELPATH)
-csl_utils_common_SOCLIST = tda2xx am572x dra7xx tda2ex am571x tda3xx
-export csl_utils_common_SOCLIST
-csl_utils_common_$(SOC)_CORELIST = $(DEFAULT_$(SOC)_CORELIST)
-export csl_utils_common_$(SOC)_CORELIST
-
-#
-# CSL Examples
-#
-
-# EDMA test app
-csl_edma_polled_mode_test_app_COMP_LIST = csl_edma_polled_mode_test_app
-csl_edma_polled_mode_test_app_RELPATH = ti/csl/example/edma/edma_polled_mode_test
-csl_edma_polled_mode_test_app_PATH = $(pdk_PATH)/$(csl_edma_polled_mode_test_app_RELPATH)
-csl_edma_polled_mode_test_app_PLATFORM_DEPENDENCY = yes
-csl_edma_polled_mode_test_app_CORE_DEPENDENCY = no
-export csl_edma_polled_mode_test_app_COMP_LIST
-export csl_edma_polled_mode_test_app_PLATFORM_DEPENDENCY
-export csl_edma_polled_mode_test_app_CORE_DEPENDENCY
-csl_edma_polled_mode_test_app_PKG_LIST = csl_edma_polled_mode_test_app
-csl_edma_polled_mode_test_app_INCLUDE = $(pdk_PATH)/$(csl_edma_polled_mode_test_app_RELPATH)
-csl_edma_polled_mode_test_app_SOCLIST = tda2xx am572x tda2ex am571x tda3xx
-export csl_edma_polled_mode_test_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex am571x am572x))
-csl_edma_polled_mode_test_app_$(SOC)_CORELIST = a15_0 ipu1_0 c66x
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_edma_polled_mode_test_app_$(SOC)_CORELIST = ipu1_0 c66x
-endif
-export csl_edma_polled_mode_test_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_edma_polled_mode_test_app
-
-# I2C led blink app
-csl_i2c_led_blink_app_COMP_LIST = csl_i2c_led_blink_app
-csl_i2c_led_blink_app_RELPATH = ti/csl/example/i2c/i2c_led_blink
-csl_i2c_led_blink_app_PATH = $(pdk_PATH)/$(csl_i2c_led_blink_app_RELPATH)
-csl_i2c_led_blink_app_PLATFORM_DEPENDENCY = yes
-csl_i2c_led_blink_app_CORE_DEPENDENCY = no
-export csl_i2c_led_blink_app_COMP_LIST
-export csl_i2c_led_blink_app_PLATFORM_DEPENDENCY
-export csl_i2c_led_blink_app_CORE_DEPENDENCY
-csl_i2c_led_blink_app_PKG_LIST = csl_i2c_led_blink_app
-csl_i2c_led_blink_app_INCLUDE = $(pdk_PATH)/$(csl_i2c_led_blink_app_RELPATH)
-csl_i2c_led_blink_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_i2c_led_blink_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_i2c_led_blink_app_$(SOC)_CORELIST = a15_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_i2c_led_blink_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_i2c_led_blink_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_i2c_led_blink_app
-
-# MAILBOX test app
-csl_mailbox_sender_receiver_app_COMP_LIST = csl_mailbox_sender_receiver_app
-csl_mailbox_sender_receiver_app_RELPATH = ti/csl/example/mailbox/mailbox_sender_receiver_app
-csl_mailbox_sender_receiver_app_PATH = $(pdk_PATH)/$(csl_mailbox_sender_receiver_app_RELPATH)
-csl_mailbox_sender_receiver_app_PLATFORM_DEPENDENCY = yes
-csl_mailbox_sender_receiver_app_CORE_DEPENDENCY = no
-export csl_mailbox_sender_receiver_app_COMP_LIST
-export csl_mailbox_sender_receiver_app_PLATFORM_DEPENDENCY
-export csl_mailbox_sender_receiver_app_CORE_DEPENDENCY
-csl_mailbox_sender_receiver_app_PKG_LIST = csl_mailbox_sender_receiver_app
-csl_mailbox_sender_receiver_app_INCLUDE = $(pdk_PATH)/$(csl_mailbox_sender_receiver_app_RELPATH)
-csl_mailbox_sender_receiver_app_SOCLIST = tda2xx am572x tda2ex am571x tda3xx
-export csl_mailbox_sender_receiver_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex am571x am572x))
-csl_mailbox_sender_receiver_app_$(SOC)_CORELIST = a15_0 ipu1_0 c66x
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_mailbox_sender_receiver_app_$(SOC)_CORELIST = ipu1_0 c66x
-endif
-export csl_mailbox_sender_receiver_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_mailbox_sender_receiver_app
-
-# UART test app
-csl_uart_test_app_COMP_LIST = csl_uart_test_app
-csl_uart_test_app_RELPATH = ti/csl/example/uart/uart_test
-csl_uart_test_app_PATH = $(pdk_PATH)/$(csl_uart_test_app_RELPATH)
-csl_uart_test_app_PLATFORM_DEPENDENCY = yes
-csl_uart_test_app_CORE_DEPENDENCY = no
-export csl_uart_test_app_COMP_LIST
-export csl_uart_test_app_PLATFORM_DEPENDENCY
-export csl_uart_test_app_CORE_DEPENDENCY
-csl_uart_test_app_PKG_LIST = csl_uart_test_app
-csl_uart_test_app_INCLUDE = $(pdk_PATH)/$(csl_uart_test_app_RELPATH)
-csl_uart_test_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_uart_test_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_uart_test_app_$(SOC)_CORELIST = a15_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_uart_test_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_uart_test_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_uart_test_app
-
-# MCASP transmit app
-csl_mcasp_transmit_app_COMP_LIST = csl_mcasp_transmit_app
-csl_mcasp_transmit_app_RELPATH = ti/csl/example/mcasp/mcasp_transmit
-csl_mcasp_transmit_app_PATH = $(pdk_PATH)/$(csl_mcasp_transmit_app_RELPATH)
-csl_mcasp_transmit_app_PLATFORM_DEPENDENCY = yes
-csl_mcasp_transmit_app_CORE_DEPENDENCY = no
-export csl_mcasp_transmit_app_COMP_LIST
-export csl_mcasp_transmit_app_PLATFORM_DEPENDENCY
-export csl_mcasp_transmit_app_CORE_DEPENDENCY
-csl_mcasp_transmit_app_PKG_LIST = csl_mcasp_transmit_app
-csl_mcasp_transmit_app_INCLUDE = $(pdk_PATH)/$(csl_mcasp_transmit_app_RELPATH)
-csl_mcasp_transmit_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_mcasp_transmit_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_mcasp_transmit_app_$(SOC)_CORELIST = a15_0 ipu1_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_mcasp_transmit_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_mcasp_transmit_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_mcasp_transmit_app
-
-# MCSPI masterSlave app
-csl_mcspiMasterSlave_app_COMP_LIST = csl_mcspiMasterSlave_app
-csl_mcspiMasterSlave_app_RELPATH = ti/csl/example/mcspi/mcspiMasterSlave
-csl_mcspiMasterSlave_app_PATH = $(pdk_PATH)/$(csl_mcspiMasterSlave_app_RELPATH)
-csl_mcspiMasterSlave_app_PLATFORM_DEPENDENCY = yes
-csl_mcspiMasterSlave_app_CORE_DEPENDENCY = no
-export csl_mcspiMasterSlave_app_COMP_LIST
-export csl_mcspiMasterSlave_app_PLATFORM_DEPENDENCY
-export csl_mcspiMasterSlave_app_CORE_DEPENDENCY
-csl_mcspiMasterSlave_app_PKG_LIST = csl_mcspiMasterSlave_app
-csl_mcspiMasterSlave_app_INCLUDE = $(pdk_PATH)/$(csl_mcspiMasterSlave_app_RELPATH)
-csl_mcspiMasterSlave_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_mcspiMasterSlave_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_mcspiMasterSlave_app_$(SOC)_CORELIST = a15_0 ipu1_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_mcspiMasterSlave_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_mcspiMasterSlave_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_mcspiMasterSlave_app
-
-# SPINLOCK test app
-csl_spinlock_test_app_COMP_LIST = csl_spinlock_test_app
-csl_spinlock_test_app_RELPATH = ti/csl/example/spinlock/spinlock_test
-csl_spinlock_test_app_PATH = $(pdk_PATH)/$(csl_spinlock_test_app_RELPATH)
-csl_spinlock_test_app_PLATFORM_DEPENDENCY = yes
-csl_spinlock_test_app_CORE_DEPENDENCY = no
-export csl_spinlock_test_app_COMP_LIST
-export csl_spinlock_test_app_PLATFORM_DEPENDENCY
-export csl_spinlock_test_app_CORE_DEPENDENCY
-csl_spinlock_test_app_PKG_LIST = csl_spinlock_test_app
-csl_spinlock_test_app_INCLUDE = $(pdk_PATH)/$(csl_spinlock_test_app_RELPATH)
-csl_spinlock_test_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_spinlock_test_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_spinlock_test_app_$(SOC)_CORELIST = a15_0 ipu1_0 c66x
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_spinlock_test_app_$(SOC)_CORELIST = ipu1_0 c66x
-endif
-export csl_spinlock_test_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_spinlock_test_app
-
-# GPIO test app
-csl_gpio_toggle_app_COMP_LIST = csl_gpio_toggle_app
-csl_gpio_toggle_app_RELPATH = ti/csl/example/gpio/gpio_toggle
-csl_gpio_toggle_app_PATH = $(pdk_PATH)/$(csl_gpio_toggle_app_RELPATH)
-csl_gpio_toggle_app_PLATFORM_DEPENDENCY = yes
-csl_gpio_toggle_app_CORE_DEPENDENCY = no
-export csl_gpio_toggle_app_COMP_LIST
-export csl_gpio_toggle_app_PLATFORM_DEPENDENCY
-export csl_gpio_toggle_app_CORE_DEPENDENCY
-csl_gpio_toggle_app_PKG_LIST = csl_gpio_toggle_app
-csl_gpio_toggle_app_INCLUDE = $(pdk_PATH)/$(csl_gpio_toggle_app_RELPATH)
-csl_gpio_toggle_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_gpio_toggle_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_gpio_toggle_app_$(SOC)_CORELIST = a15_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_gpio_toggle_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_gpio_toggle_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_gpio_toggle_app
-
-# MMCSD raw access app
-csl_mmc_raw_access_app_COMP_LIST = csl_mmc_raw_access_app
-csl_mmc_raw_access_app_RELPATH = ti/csl/example/mmcsd/mmc_raw_access
-csl_mmc_raw_access_app_PATH = $(pdk_PATH)/$(csl_mmc_raw_access_app_RELPATH)
-csl_mmc_raw_access_app_PLATFORM_DEPENDENCY = yes
-csl_mmc_raw_access_app_CORE_DEPENDENCY = no
-export csl_mmc_raw_access_app_COMP_LIST
-export csl_mmc_raw_access_app_PLATFORM_DEPENDENCY
-export csl_mmc_raw_access_app_CORE_DEPENDENCY
-csl_mmc_raw_access_app_PKG_LIST = csl_mmc_raw_access_app
-csl_mmc_raw_access_app_INCLUDE = $(pdk_PATH)/$(csl_mmc_raw_access_app_RELPATH)
-csl_mmc_raw_access_app_SOCLIST = tda2xx am572x tda2ex am571x
-export csl_mmc_raw_access_app_SOCLIST
-csl_mmc_raw_access_app_$(SOC)_CORELIST = a15_0
-export csl_mmc_raw_access_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_mmc_raw_access_app
-
-# DCAN test app
-csl_dcanLoopback_app_COMP_LIST = csl_dcanLoopback_app
-csl_dcanLoopback_app_RELPATH = ti/csl/example/dcan/dcanLoopback
-csl_dcanLoopback_app_PATH = $(pdk_PATH)/$(csl_dcanLoopback_app_RELPATH)
-csl_dcanLoopback_app_PLATFORM_DEPENDENCY = yes
-csl_dcanLoopback_app_CORE_DEPENDENCY = no
-export csl_dcanLoopback_app_COMP_LIST
-export csl_dcanLoopback_app_PLATFORM_DEPENDENCY
-export csl_dcanLoopback_app_CORE_DEPENDENCY
-csl_dcanLoopback_app_PKG_LIST = csl_dcanLoopback_app
-csl_dcanLoopback_app_INCLUDE = $(pdk_PATH)/$(csl_dcanLoopback_app_RELPATH)
-csl_dcanLoopback_app_SOCLIST = tda2xx am572x tda2ex am571x tda3xx
-export csl_dcanLoopback_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex am571x am572x))
-csl_dcanLoopback_app_$(SOC)_CORELIST = a15_0 ipu1_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_dcanLoopback_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_dcanLoopback_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_dcanLoopback_app
-
-# QSPI test app
-csl_qspi_test_app_COMP_LIST = csl_qspi_test_app
-csl_qspi_test_app_RELPATH = ti/csl/example/qspi/qspi_test
-csl_qspi_test_app_PATH = $(pdk_PATH)/$(csl_qspi_test_app_RELPATH)
-csl_qspi_test_app_PLATFORM_DEPENDENCY = yes
-csl_qspi_test_app_CORE_DEPENDENCY = no
-export csl_qspi_test_app_COMP_LIST
-export csl_qspi_test_app_PLATFORM_DEPENDENCY
-export csl_qspi_test_app_CORE_DEPENDENCY
-csl_qspi_test_app_PKG_LIST = csl_qspi_test_app
-csl_qspi_test_app_INCLUDE = $(pdk_PATH)/$(csl_qspi_test_app_RELPATH)
-csl_qspi_test_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_qspi_test_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_qspi_test_app_$(SOC)_CORELIST = a15_0 ipu1_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_qspi_test_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_qspi_test_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_qspi_test_app
-
-# GPMC test app
-csl_nor_read_write_app_COMP_LIST = csl_nor_read_write_app
-csl_nor_read_write_app_RELPATH = ti/csl/example/gpmc/nor_read_write
-csl_nor_read_write_app_PATH = $(pdk_PATH)/$(csl_nor_read_write_app_RELPATH)
-csl_nor_read_write_app_PLATFORM_DEPENDENCY = yes
-csl_nor_read_write_app_CORE_DEPENDENCY = no
-export csl_nor_read_write_app_COMP_LIST
-export csl_nor_read_write_app_PLATFORM_DEPENDENCY
-export csl_nor_read_write_app_CORE_DEPENDENCY
-csl_nor_read_write_app_PKG_LIST = csl_nor_read_write_app
-csl_nor_read_write_app_INCLUDE = $(pdk_PATH)/$(csl_nor_read_write_app_RELPATH)
-csl_nor_read_write_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_nor_read_write_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_nor_read_write_app_$(SOC)_CORELIST = a15_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_nor_read_write_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_nor_read_write_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_nor_read_write_app
-
-# WDTIMER test app
-csl_wdtimer_reset_app_COMP_LIST = csl_wdtimer_reset_app
-csl_wdtimer_reset_app_RELPATH = ti/csl/example/wdtimer/wdtimer_reset_app
-csl_wdtimer_reset_app_PATH = $(pdk_PATH)/$(csl_wdtimer_reset_app_RELPATH)
-csl_wdtimer_reset_app_PLATFORM_DEPENDENCY = yes
-csl_wdtimer_reset_app_CORE_DEPENDENCY = no
-export csl_wdtimer_reset_app_COMP_LIST
-export csl_wdtimer_reset_app_PLATFORM_DEPENDENCY
-export csl_wdtimer_reset_app_CORE_DEPENDENCY
-csl_wdtimer_reset_app_PKG_LIST = csl_wdtimer_reset_app
-csl_wdtimer_reset_app_INCLUDE = $(pdk_PATH)/$(csl_wdtimer_reset_app_RELPATH)
-csl_wdtimer_reset_app_SOCLIST = tda2xx tda2ex
-export csl_wdtimer_reset_app_SOCLIST
-csl_wdtimer_reset_app_$(SOC)_CORELIST = a15_0
-export csl_wdtimer_reset_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_wdtimer_reset_app
-
-# TIMER test app
-csl_timer_app_COMP_LIST = csl_timer_app
-csl_timer_app_RELPATH = ti/csl/example/timer/timer_app
-csl_timer_app_PATH = $(pdk_PATH)/$(csl_timer_app_RELPATH)
-csl_timer_app_PLATFORM_DEPENDENCY = yes
-csl_timer_app_CORE_DEPENDENCY = no
-export csl_timer_app_COMP_LIST
-export csl_timer_app_PLATFORM_DEPENDENCY
-export csl_timer_app_CORE_DEPENDENCY
-csl_timer_app_PKG_LIST = csl_timer_app
-csl_timer_app_INCLUDE = $(pdk_PATH)/$(csl_timer_app_RELPATH)
-csl_timer_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_timer_app_SOCLIST
-ifeq ($(SOC),$(filter $(SOC), tda2xx tda2ex))
-csl_timer_app_$(SOC)_CORELIST = a15_0 ipu1_0
-endif
-ifeq ($(SOC),$(filter $(SOC), tda3xx))
-csl_timer_app_$(SOC)_CORELIST = ipu1_0
-endif
-export csl_timer_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_timer_app
-
-# PCIE EP WRITE test app
-csl_ep_write_loopback_app_COMP_LIST = csl_ep_write_loopback_app
-csl_ep_write_loopback_app_RELPATH = ti/csl/example/pcie/write_loopback/ep
-csl_ep_write_loopback_app_PATH = $(pdk_PATH)/$(csl_ep_write_loopback_app_RELPATH)
-csl_ep_write_loopback_app_PLATFORM_DEPENDENCY = yes
-csl_ep_write_loopback_app_CORE_DEPENDENCY = no
-export csl_ep_write_loopback_app_COMP_LIST
-export csl_ep_write_loopback_app_PLATFORM_DEPENDENCY
-export csl_ep_write_loopback_app_CORE_DEPENDENCY
-csl_ep_write_loopback_app_PKG_LIST = csl_ep_write_loopback_app
-csl_ep_write_loopback_app_INCLUDE = $(pdk_PATH)/$(csl_ep_write_loopback_app_RELPATH)
-csl_ep_write_loopback_app_SOCLIST = tda2xx tda2ex
-export csl_ep_write_loopback_app_SOCLIST
-csl_ep_write_loopback_app_$(SOC)_CORELIST = a15_0
-export csl_ep_write_loopback_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_ep_write_loopback_app
-
-# PCIE RC WRITE test app
-csl_rc_write_loopback_app_COMP_LIST = csl_rc_write_loopback_app
-csl_rc_write_loopback_app_RELPATH = ti/csl/example/pcie/write_loopback/rc
-csl_rc_write_loopback_app_PATH = $(pdk_PATH)/$(csl_rc_write_loopback_app_RELPATH)
-csl_rc_write_loopback_app_PLATFORM_DEPENDENCY = yes
-csl_rc_write_loopback_app_CORE_DEPENDENCY = no
-export csl_rc_write_loopback_app_COMP_LIST
-export csl_rc_write_loopback_app_PLATFORM_DEPENDENCY
-export csl_rc_write_loopback_app_CORE_DEPENDENCY
-csl_rc_write_loopback_app_PKG_LIST = csl_rc_write_loopback_app
-csl_rc_write_loopback_app_INCLUDE = $(pdk_PATH)/$(csl_rc_write_loopback_app_RELPATH)
-csl_rc_write_loopback_app_SOCLIST = tda2xx tda2ex
-export csl_rc_write_loopback_app_SOCLIST
-csl_rc_write_loopback_app_$(SOC)_CORELIST = a15_0
-export csl_rc_write_loopback_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_rc_write_loopback_app
-
-# MMU test app
-csl_mmu_tlb_twl_app_COMP_LIST = csl_mmu_tlb_twl_app
-csl_mmu_tlb_twl_app_RELPATH = ti/csl/example/mmu/mmu_tlb_twl
-csl_mmu_tlb_twl_app_PATH = $(pdk_PATH)/$(csl_mmu_tlb_twl_app_RELPATH)
-csl_mmu_tlb_twl_app_PLATFORM_DEPENDENCY = yes
-csl_mmu_tlb_twl_app_CORE_DEPENDENCY = no
-export csl_mmu_tlb_twl_app_COMP_LIST
-export csl_mmu_tlb_twl_app_PLATFORM_DEPENDENCY
-export csl_mmu_tlb_twl_app_CORE_DEPENDENCY
-csl_mmu_tlb_twl_app_PKG_LIST = csl_mmu_tlb_twl_app
-csl_mmu_tlb_twl_app_INCLUDE = $(pdk_PATH)/$(csl_mmu_tlb_twl_app_RELPATH)
-csl_mmu_tlb_twl_app_SOCLIST = tda2xx tda2ex tda3xx
-export csl_mmu_tlb_twl_app_SOCLIST
-csl_mmu_tlb_twl_app_$(SOC)_CORELIST = c66x
-export csl_mmu_tlb_twl_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_mmu_tlb_twl_app
-
-# CRC test app
-csl_crc_semicputest_app_COMP_LIST = csl_crc_semicputest_app
-csl_crc_semicputest_app_RELPATH = ti/csl/example/crc/crc_semicputest_app
-csl_crc_semicputest_app_PATH = $(pdk_PATH)/$(csl_crc_semicputest_app_RELPATH)
-csl_crc_semicputest_app_PLATFORM_DEPENDENCY = yes
-csl_crc_semicputest_app_CORE_DEPENDENCY = no
-export csl_crc_semicputest_app_COMP_LIST
-export csl_crc_semicputest_app_PLATFORM_DEPENDENCY
-export csl_crc_semicputest_app_CORE_DEPENDENCY
-csl_crc_semicputest_app_PKG_LIST = csl_crc_semicputest_app
-csl_crc_semicputest_app_INCLUDE = $(pdk_PATH)/$(csl_crc_semicputest_app_RELPATH)
-csl_crc_semicputest_app_SOCLIST = tda3xx
-export csl_crc_semicputest_app_SOCLIST
-csl_crc_semicputest_app_$(SOC)_CORELIST = ipu1_0 c66x
-export csl_crc_semicputest_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_crc_semicputest_app
-
-# ESM test app
-csl_esm_eve_reset_test_app_COMP_LIST = csl_esm_eve_reset_test_app
-csl_esm_eve_reset_test_app_RELPATH = ti/csl/example/esm/esm_eve_reset_test_app
-csl_esm_eve_reset_test_app_PATH = $(pdk_PATH)/$(csl_esm_eve_reset_test_app_RELPATH)
-csl_esm_eve_reset_test_app_PLATFORM_DEPENDENCY = yes
-csl_esm_eve_reset_test_app_CORE_DEPENDENCY = no
-export csl_esm_eve_reset_test_app_COMP_LIST
-export csl_esm_eve_reset_test_app_PLATFORM_DEPENDENCY
-export csl_esm_eve_reset_test_app_CORE_DEPENDENCY
-csl_esm_eve_reset_test_app_PKG_LIST = csl_esm_eve_reset_test_app
-csl_esm_eve_reset_test_app_INCLUDE = $(pdk_PATH)/$(csl_esm_eve_reset_test_app_RELPATH)
-csl_esm_eve_reset_test_app_SOCLIST = tda3xx
-export csl_esm_eve_reset_test_app_SOCLIST
-csl_esm_eve_reset_test_app_$(SOC)_CORELIST = ipu1_0
-export csl_esm_eve_reset_test_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_esm_eve_reset_test_app
-
-# DCC test app
-csl_dcc_singleshotmode_app_COMP_LIST = csl_dcc_singleshotmode_app
-csl_dcc_singleshotmode_app_RELPATH = ti/csl/example/dcc/dcc_singleshotmode_app
-csl_dcc_singleshotmode_app_PATH = $(pdk_PATH)/$(csl_dcc_singleshotmode_app_RELPATH)
-csl_dcc_singleshotmode_app_PLATFORM_DEPENDENCY = yes
-csl_dcc_singleshotmode_app_CORE_DEPENDENCY = no
-export csl_dcc_singleshotmode_app_COMP_LIST
-export csl_dcc_singleshotmode_app_PLATFORM_DEPENDENCY
-export csl_dcc_singleshotmode_app_CORE_DEPENDENCY
-csl_dcc_singleshotmode_app_PKG_LIST = csl_dcc_singleshotmode_app
-csl_dcc_singleshotmode_app_INCLUDE = $(pdk_PATH)/$(csl_dcc_singleshotmode_app_RELPATH)
-csl_dcc_singleshotmode_app_SOCLIST = tda3xx
-export csl_dcc_singleshotmode_app_SOCLIST
-csl_dcc_singleshotmode_app_$(SOC)_CORELIST = ipu1_0
-export csl_dcc_singleshotmode_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_dcc_singleshotmode_app
-
-# RTI test app
-csl_rti_dwwdtest_app_COMP_LIST = csl_rti_dwwdtest_app
-csl_rti_dwwdtest_app_RELPATH = ti/csl/example/rti/rti_dwwdtest_app
-csl_rti_dwwdtest_app_PATH = $(pdk_PATH)/$(csl_rti_dwwdtest_app_RELPATH)
-csl_rti_dwwdtest_app_PLATFORM_DEPENDENCY = yes
-csl_rti_dwwdtest_app_CORE_DEPENDENCY = no
-export csl_rti_dwwdtest_app_COMP_LIST
-export csl_rti_dwwdtest_app_PLATFORM_DEPENDENCY
-export csl_rti_dwwdtest_app_CORE_DEPENDENCY
-csl_rti_dwwdtest_app_PKG_LIST = csl_rti_dwwdtest_app
-csl_rti_dwwdtest_app_INCLUDE = $(pdk_PATH)/$(csl_rti_dwwdtest_app_RELPATH)
-csl_rti_dwwdtest_app_SOCLIST = tda3xx
-export csl_rti_dwwdtest_app_SOCLIST
-csl_rti_dwwdtest_app_$(SOC)_CORELIST = ipu1_0
-export csl_rti_dwwdtest_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_rti_dwwdtest_app
-
-# ADC test app
-csl_adc_singleshot_test_app_COMP_LIST = csl_adc_singleshot_test_app
-csl_adc_singleshot_test_app_RELPATH = ti/csl/example/adc/adc_singleshot_test_app
-csl_adc_singleshot_test_app_PATH = $(pdk_PATH)/$(csl_adc_singleshot_test_app_RELPATH)
-csl_adc_singleshot_test_app_PLATFORM_DEPENDENCY = yes
-csl_adc_singleshot_test_app_CORE_DEPENDENCY = no
-export csl_adc_singleshot_test_app_COMP_LIST
-export csl_adc_singleshot_test_app_PLATFORM_DEPENDENCY
-export csl_adc_singleshot_test_app_CORE_DEPENDENCY
-csl_adc_singleshot_test_app_PKG_LIST = csl_adc_singleshot_test_app
-csl_adc_singleshot_test_app_INCLUDE = $(pdk_PATH)/$(csl_adc_singleshot_test_app_RELPATH)
-csl_adc_singleshot_test_app_SOCLIST = tda3xx
-export csl_adc_singleshot_test_app_SOCLIST
-csl_adc_singleshot_test_app_$(SOC)_CORELIST = ipu1_0
-export csl_adc_singleshot_test_app_$(SOC)_CORELIST
-csl_EXAMPLE_LIST += csl_adc_singleshot_test_app
-
-export csl_LIB_LIST
-export csl_EXAMPLE_LIST
-
-csl_component_make_include := 1
-endif