]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - sitara-linux/meta-custom.git/commitdiff
Lab1 Lab1-7.0-alpha
authorFranklin S Cooper Jr <fcooper@ti.com>
Thu, 25 Jul 2013 19:10:23 +0000 (14:10 -0500)
committerFranklin S Cooper Jr <fcooper@ti.com>
Wed, 4 Dec 2013 18:15:48 +0000 (12:15 -0600)
Signed-off-by: Franklin S Cooper Jr <fcooper@ti.com>
conf/layer.conf [new file with mode: 0644]
recipes-core/hello-world/hello-world_1.0.bb [new file with mode: 0644]

diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644 (file)
index 0000000..499e4b2
--- /dev/null
@@ -0,0 +1,24 @@
+# It really depends on order of the layers appearing in BBLAYERS
+# variable in toplevel bblayers.conf file, where bitbake will search
+# for .inc files and others where bitbake uses BBPATH since it will
+# search the directories from first to last as specified in BBPATH
+# Therefore if you want a given layer to be considered high priority
+# for the .inc and .conf etc. then consider it adding at the beginning
+# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
+# the recipe contention so the order of directories in BBFILES does 
+# not matter.
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "<unique name>"
+BBFILE_PATTERN_<unique name> := "^${LAYERDIR}/"
+
+# Define the priority for recipes (.bb files) from this layer,
+# choosing carefully how this layer interacts with all of the
+# other layers.
+
+BBFILE_PRIORITY_<unique name> = "<priority value>"
diff --git a/recipes-core/hello-world/hello-world_1.0.bb b/recipes-core/hello-world/hello-world_1.0.bb
new file mode 100644 (file)
index 0000000..0d863c1
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "Hello World"
+HOMEPAGE = "https://gitorious.org/sitara-bootcamp/hello-world"
+SECTION = "console"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8d30c2460fbf3f17135994e5c6ead1f3"
+
+PR = "r0"
+
+# Commit id/hash associated with the specific git commit that you want to use.
+SRCREV = "57a46eadb835a3951db79e0de3d1226ccd1092a4"
+
+SRC_URI = "git://gitorious.org/sitara-bootcamp/hello-world.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE += "release"
+
+do_install() {
+    # By default ${bindir} = /usr/bin
+       install -d ${D}${bindir}
+
+    # Install hello-world at /usr/bin on the filesystem.
+    install -m 0755 ${S}/Release/hello-world ${D}${bindir}
+}
+
+FILES_${PN} += "${bindir}/hello-world"